Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried everything I can think of, asking in a forum in spanish, uninstalling flash, looking for 64 bit versions, sorry but my mind just does not have another idea here and I'm absolutely and totally frustrated.

Problem is that if I go to and click on a video to watch, it won't play. The player will load, meaning that I can see the black square with the play button and everything, but, a few seconds later, it just says "there has been an error, try again later" and every single time I try, the exact same problem occurs. To make things even odder, if I go to whatever video website it'll work just fine, so you name it (vimeo, metacafe, etc.) they all work except youtube.

As I said I am extremely frustrated because I've tried everything I can think of, and nothing has had good results here.

share|improve this question
Is this works well in windows or any other software ? I faced similar problems when due to some settings in broadband router (I am unable to recollect now). Windows worked for 5 minutes..and then will not work, Ubuntu will not work at all – Jamess May 30 '13 at 11:29
Are you at work, at school, or in a coffee shop? – Alaa Ali May 30 '13 at 11:54
Clear cache, cookie and Internet data from the browser and restart. – Nabil May 30 '13 at 11:58
try diffrent browser – kubahaha May 30 '13 at 12:36
1.- Yes it works in windows very well 2.- I'm home 3.- Cache cleared in Chromium and Firefox, no Results at all, still having issues 4.- Installig Epiphany, Slimboat and Dooble to see what happens – Irving May 30 '13 at 14:37

I believe you are (or not are) in the HTML5 Video Player trial. Visit this link if you are inside the trial just opt-out, if you are out, you may like to opt-in while flash is broken.

I would recommend you to check and see what version of flash you have installed. You may also purge the plugin and upgrade Firefox.

sudo apt-get purge flashplugin-installer
sudo apt-get upgrade

Or try an alternative like Gnash:

sudo apt-get install gnash
share|improve this answer

You can try to Re-install the Ubuntu Restricted Extras package, based on this answer to this question: YouTube Videos Stopped Streaming and Why do I have problems seeing YouTube??

share|improve this answer

protected by Community Sep 27 '13 at 4:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.