Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't seem to get the dependencies installed for the icaclient on 13.04.

test@ubuntu:~$ sudo apt-get install nspluginwrapper
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nspluginwrapper : Depends: nspluginviewer (= 1.4.4-0ubuntu5) but it is not installable
E: Unable to correct problems, you have held broken packages.

Tried installing nspluginviewer...

test@ubuntu:~$ sudo apt-get install nspluginviewer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package nspluginviewer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nspluginviewer' has no installation candidate

Any ideas? All of the docs say to install nspluginwrapper before icaclient, but I can't get it to work..

Thanks!

share|improve this question

closed as off-topic by Richard, i08in, Warren Hill, Ask, Avinash Raj Apr 14 at 11:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers 2

nspluginviewer is not available for 64 bit version. Refer http://packages.ubuntu.com/raring/nspluginviewer

Follow these instructions to install 32 bit version of it

  1. wget http://ubuntu.wikimedia.org/ubuntu//pool/multiverse/n/nspluginwrapper/nspluginviewer_1.4.4-0ubuntu5_i386.deb
  2. sudo dpkg -i nspluginviewer_1.4.4-0ubuntu5_i386.deb
share|improve this answer
    
test@ubuntu:~$ sudo dpkg -i nspluginviewer_1.4.4-0ubuntu5_i386.deb [sudo] password for test: dpkg: error processing nspluginviewer_1.4.4-0ubuntu5_i386.deb (--install): package architecture (i386) does not match system (amd64) Errors were encountered while processing: nspluginviewer_1.4.4-0ubuntu5_i386.deb - -Still getting an error. It seems that I can't install 32 bit versions of software on a 64-bit machine. –  Lance Collins May 30 '13 at 11:29
add comment

Thank you, thefourtheye. Finally two lines of code that did it for me (Ubuntu 13.04)!

The installation was successful but during launch my application got SSL Certificate Error. To fix the error on Firefox do the following: sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.