Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set a cluster using mysql-cluster-gpl-7.2.12, first it was working fine but suddenly started to fail. I can start the nodes (ndbd) but when I try to start mysqld (API), it shows an error it says "The server quit without PID file (path/dbnode1.pid).

I removed ibdata1 and rebuilt the database using the command ./scripts/mysql_install_db --user=mysql to create it again but it doesn't start, moved my.cnf file and it didn't work.

Do you have any tips?

share|improve this question
add comment

1 Answer 1

I've had this issue a couple of times. Fixed it once, still working on the last one. The one time I got it going I used brute force; I re-installed mysql-cluster (replacing existing files and packages) and since my config and start scripts were in custom directories they were unaffected. A reboot and auto-magically things worked. I think I had had an odd file permissions issue that the re-install fixed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.