Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's been well over six months but I have the same router SmartAX MT880d with Ethernet, and the exact same problem : no internet, even though I can successfully reach the modem settings page by entering 192.168.1.1 in Firefox.

I'm a total beginner with Ubuntu. My internet works great in Windows but does not work in Ubuntu.

Sorry if I don't use the right (technical) terminology to explain my issue. English is not my mother tongue.

For 2 weeks, I've been doing reading on the web and forums and the ubuntuguide.org to name a few, but to no avail. Now I see no other solution but to ask for help.

My problem is that I can't find a way to put the right digits in the right place because I don't know what numbers I need to put in what files. E.g.: do I need to use DHCP? or a static IP address? No clue whatsoever. I'm concerned that I might put figures in the wrong spaces. For example, is the modem/router's IP exactly 192.168.1.1 for Huawei Smart AXMT880d modem? Is the subnet 255.255.255.0? Gateway 192.168.1.1?

I'm confused as I can also see a different IP starting with 155131*** (is it an account number?) on my contract with Huawei (a Chinese ISP).

  • Apart from calling 911, what other numbers do I need to put in and where?
  • How do I check that all the numbers have been entered correctly in every appropriate space before trying to connect the Internet?

Further development of the issue:

First as per the post below, I successfully disabled IPv6 from article called "Simple Way to Disable IPv6 in Windows Vista". Then I tried connecting to the Internet in Ubuntu, to no avail again.

Then I checked my settings in Ubuntu. I typed /etc/network/interfaces. There appears the loopback setting only, i.e.

auto lo
iface lo inet loopback

I also checked /etc/resolv.conf but it's empty.

At this stage, the network manager still does not detect anything even after having disabled IPv6.

Then I tried Scaine's suggestion about pppoeconf coming from an article translated from Chinese. So I did the steps below and rebooted as the restart option (last step of the procedure below) has frozen for 2 minutes before i decided to reboot...(is that supposed to freeze at this stage??):


Basically, from the article (I have obviously not tested this!):

sudo apt-get install pppoeconf

To start the ADSL connection when needed, in a terminal, sudo pon dsl-provider To disconnect the ADSL connection, you can enter in a terminal, sudo poff If you need to check the log, you can enter in a terminal plog. Access to interface information in a terminal type ifconfig ppp0

After using the pppoeconf if Network Manager does not display hosted solution:

Enter the following command in a terminal to configure a network connection : sudo gedit /etc/NetworkManager/nm-system-settings.conf and change

[ifupdown] managed = false

to

[ifupdown] managed = true 

Then in terminal run sudo gedit /etc/network/interfaces and keep only :

auto lo
iface lo inet loopback

Delete dns settings sudo mv /etc/resolv.conf /etc/resolv.conf_backup

Finally restart network-manager: sudo service network-manager restart


After that, the settings remained the same. That is, in /etc/network/interfaces, still the loopback settings, and /etc/resolv.conf is still empty.

Then, I tried Simon Bridge's advice about pppoeconf (in post #8)

I tried that pppoeconf before registering on AskUbuntu.com and after reading and trying everything in this thread (until 16th March 2011).

My view on the topic is that by having tested many things different tips one after the other, I may have mixed settings in the end.

TO SUM UP NOW:

  • IPv6 is disabled. In addition, in ipconfig /all in windows, I now noticed that DHCP is on for the Wireless LAN Adapter Wireless Network Connection, and Ethernet adapter Local Area Connection just shows the description of it: VIA VelocityFamily Gigabit Ethernet Adapter. That's it. The Ethernet is not "on" anymore. What should I do now??? Setting the IP address maybe???
  • As a result, DHCP is on in Windows (for the wireless) but still does not auto-detect anything yet (same thing for DHCP as a matter of fact. For the wireless, no detection although i can see the different wireless networks)
  • pppoeconf does not detect anything either after having done everything below.

Therefore, I think there's a setting which has not been set correctly somewhere but where? That remains a question...Thx anyway to you all. If you have any suggestion... I'm grateful to you anyway.


Edit:

Hi Scaine, here are some interesting results from pppoeconf! I think I'm about to succeed....but one more barrier below. Could you please help guide me again? What do I have to do to turn on that Internet connection? when I enter sudo pon dsl-provider, nothing (I can see) happens...

joel@ubuntu:~$ sudo pppoeconf 
[sudo] password for joel:  
Plugin rp-pppoe.so loaded. 
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5 
joel@ubuntu:~$ plog 
Mar 16 21:08:14 ubuntu pppd[1840]: Remote message: Authentication success,Welcome! 
Mar 16 21:08:14 ubuntu pppd[1840]: PAP authentication succeeded 
Mar 16 21:08:14 ubuntu pppd[1840]: peer from calling number 00:25:9E:F1:C1:9C authorized 
Mar 16 21:08:14 ubuntu pppd[1840]: Cannot determine ethernet address for proxy ARP 
Mar 16 21:08:14 ubuntu pppd[1840]: local  IP address 27.190.153.195 
Mar 16 21:08:14 ubuntu pppd[1840]: remote IP address 27.190.152.1 
Mar 16 21:08:14 ubuntu pppd[1840]: primary   DNS address 222.222.202.202 
Mar 16 21:08:14 ubuntu pppd[1840]: secondary DNS address 222.222.222.222 
joel@ubuntu:~$ pon dsl-provider 
Error: only members of the 'dip' group can use this command. 
joel@ubuntu:~$ sudo pon dsl-provider 
Plugin rp-pppoe.so loaded. 
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5 
share|improve this question
    
Have you tried using network-manager, instead of configuring it manually? –  Jesse Taylor Mar 13 '11 at 12:03
1  
The number you think might be a Huawei account number, is probably an account number, and I think you could safely delete it from this question. –  belacqua Mar 14 '11 at 6:32
1  
It would also be typical for your subscriber subnet to be 255.255.255.0. A gateway address of 192.168.1.1 would also be very common. Your Ubuntu system will likely need a 192.168.1.x address, where 'x' is a number between 2 and 254 (assuming your gateway is .1) I wouldn't worry about getting everything correct before attempting to connect to the internet -- just try and if it fails, make changes and try again. And Scaine's answer should get you the info you need. –  belacqua Mar 14 '11 at 6:38
    
Looks like you're asking here after this thread on linuxquestions didn't help you? linuxquestions.org/questions/linux-desktop-74/… I put this in for reference in case someone can figure out why this isn't working for you. –  Scaine Mar 14 '11 at 17:54
    
Perhaps try putting sudo in front of pppoeconf? sudo pppoeconf? –  Scaine Mar 16 '11 at 9:35

3 Answers 3

up vote 2 down vote accepted

I'm adding a separate answer here, since while my first answer is relevant generally, it looks like the SmartAX MT880d modem/router requires a different approach. I found this site which (with the help of Google Translate) outlines how to install ppoeconf and set up this modem under Ubuntu.

Basically, from the article (I have obviously not tested this!):

sudo apt-get install pppoeconf

Then run the command with sudo pppoeconf, putting your account details in, as prompted.

To start the ADSL connection when needed, in a terminal, sudo pon dsl-provider To disconnect the ADSL connection, you can enter in a terminal, sudo poff If you need to check the log, you can enter in a terminal plog. Access to interface information in a terminal type, ifconfig ppp0

After using the pppoeconf if Network Manager does not display hosted solution:

Enter the following command in a terminal to configure a network connection:

gksu gedit /etc/NetworkManager/nm-system-settings.conf

And change

[ifupdown] managed = false

to:

[ifupdown] managed = true 

Then in terminal run gksu gedit /etc/network/interfaces and keep only:

auto lo iface lo inet loopback

Delete DNS settings: sudo mv /etc/resolv.conf /etc/resolv.conf_backup

Finally restart network-manager: sudo service network-manager restart (Or reboot!)

share|improve this answer

If your PC works with this modem in Windows, it should be quite easy to copy those settings to Ubuntu. In Windows, open a command window and type ipconfig /all.

Windows command window

In this screenshot above, you can see that DHCP is not enabled, so in this case, I'd have to copy the settings down, in particular, IP Address, Subnet Mask, Default Gateway and DNS Servers.

Then in Ubuntu, we need to replicate those settings in Network Manager. So right click on the network manager applet, choose "Edit Connections", then edit your "Auto eth0" connection to match what you saw in Windows.

Network Manager settings

If DHCP was enabled, then Ubuntu should simply work, since that's its default setting.

share|improve this answer
    
Oh my god! You rock. I am going to use that tip today. I'll let you know soon. –  user12285 Mar 14 '11 at 2:28
    
thanks by the way –  user12285 Mar 14 '11 at 2:32
    
I just checked my settings on Windows. DHCP is turned off as per PPP Adapter Broadband Connection in ipconfig /all. It however shows DHCP turned on in the Ethernet Adapter Local Area Connection. As Ubuntu still doesn't auto-detect my Ethernet connection, what should I follow between setting DHCP in Ubuntu and setting the Ethernet connection in Ubuntu? To me, both are fine...but which one shall I set in the easiest way? Thanks again (I have made a great leap in my understanding of networks). –  user12285 Mar 14 '11 at 8:48
    
I don't think the PPP adapter is relevant. If the ethernet adapter in Windows says DHCP, then Ubuntu should "just work". Since it's not working, I would suspect that you might have some IPv6 issues (just guessing). Try searching this site for "disable IPv6". At work at the moment, so can't be more help until later today (about 8 hours). –  Scaine Mar 14 '11 at 10:46

Hi People of the Earth! I'm excited. i got it working... I knew I would do it...ahahahah

Thanks to everyone! After having deactivated IPv6 in Windows following this tutorial for Vista http://www.home-network-help.com/disable-ipv6.html, Scaine has helped a great deal when he led me to type "sudo pppoeconf". Then I entered the right username and password like shown on my Internet contract and always said "yes" when prompted. I then proceeded to run the plog command as you can see above in my terminal with that error message: "Mar 16 21:08:14 ubuntu pppd[1840]: Cannot determine ethernet address for proxy ARP".

Looking for that error in Google, I ran into a user called "Stween" on http://www.justlinux.com/forum/archive/index.php/t-62893.html

As suggested by that link, I entered: sudo gedit /etc/ppp/options

and just disabled an option. I went from noauth to #noauth. That is I just deactivated this option by adding # before "noauth". I saved, used the plog command again in the terminal again without sudo, and went straight online.

I hope this post help sb else as much as you have all helped me. So grateful to you (after three weeks of research) YYYYYaaaaaaaaaaaayaayyyyy!!! Note: If i reboot, will the problem come up again. Do I need to run the plog command every time...thansk a million!!!! See you soon. This website and its people are to be recommended for sure.

share|improve this answer
    
Great news - I've never used pppoeconf before, so I'm glad it's worked out for you! I have no idea if you need the plog command each time on boot, but if you do, search this site for "run command on start up" or something similar. Good luck. –  Scaine Mar 17 '11 at 13:11
    
I've rebooted my machine to test whether I needed to manually use that plog command. And apparently, it lets me in every time without typing it in. So far so good. Fingers crossed. Cheers. –  user12285 Mar 17 '11 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.