Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to develop a website in Python, and have installed VirtualBox on my Ubuntu 13.04 host. The VirtualBox is running an Ubuntu 13.04 Django stack.

I need to be able to edit the files within my VirtualBox from my Host. From what I unerstand, I need to install Guest Additions in order to share my folders from Guest to Host.

When trying to install Guest Additions, after downloading the ISO file, I get the following error :

Picture of the error message.

I've seen a lot of people reporting a similar issue, but have not found a clear fix yet.

share|improve this question

The error you get is likely because the Guest Additions CD image is already mounted.

To see all mounted drives open a terminal in the guest to issue mount. This will give you (among others) a line similar to this:

/dev/sr0 on /media/takkat/VBOXADDITIONS_4.2.12_849801 type iso9660 (ro,nosuid,nodev,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks2)

In the Unity Launcher you will see a CD-ROM icon. To unmount the CD right click on this icon and select "Eject".

enter image description here

We can not unmount the Guest Additions CD from the command line when mounted with the help of then Virtual Box Manager. Please select "Devices -> CD/DVD Devices -> Remove disk from virtual drive" and choose "Force unmount" to remove the CD iso.

To install guest additions we will have to load the CD again from Virtual Box Manager and select the Icon from the Unity Launcher.

See also the following questions which also has a command line method for installing guest additions:

share|improve this answer
Thanks you @Takkat, I now know how to unmount the iso. I read the tutorial, which asks me to install "virtualbox-guest-additions". When I write "sudo apt-get install virtualbox-guest-additions", I get the error "unable to locate package". In fact, it looks like my guest is unable to locate any package at all. Also, I don't have a GUI on my guest, so no Unity. I assumed this was normal. – MonsieurPoivron May 30 '13 at 13:46
The Guest Additions usually are an .iso file installed with Virtual Box on the host to let you mount from Virtual Box Manager. The you will have to run the installer from this CD from within the guest. Unity may only be available after having installed them from the command line (see link above). Good luck! – Takkat May 30 '13 at 14:11
It looks like the reason I couldn't just write sudo apt-get install virtualbox-guest-additions was the fact that I first needed to do sudo apt-get update. – MonsieurPoivron May 30 '13 at 14:55
sudo apt-get install virtualbox-guest-additions-iso – johndpope Jun 24 '15 at 7:53

For what it's worth, I was unable to install the guest additions until I installed the extension pack from Oracle. After that, right-ctrl+d worked like a charm.

share|improve this answer
where do you get the extension pack from oracle ? – duckx Jan 4 '14 at 0:24
It's available on the virtualbox website. – Christopher Jan 5 '14 at 3:28

I tried this and it worked:

  1. From the terminal (Ctrl+Alt+T) and enter the following commands:

    cd /mnt
    cd /cdrom
  2. From the VirtualBox menu (top left pane) go to "device" and insert guest additions (it should work this time)

  3. Then from the terminal again type:

    sudo sh /media/cdrom/
share|improve this answer

I had this problem but at the time I was running ubuntu as a guest (when you start up the system it asks if you want to install ubuntu or run as guest). As soon as I installed ubuntu on the box, the guest additions installed without any problems

share|improve this answer

my workaround in macosx 10.10 host ubuntu 12.04 guest is to copy the virtualbox guest additions iso to a shared folder and just use the terminal in my guest to run (sudo sh /pathto/

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.