Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a clean install of Xubuntu 13.04 and i am experiencing now a very slow wifi connection compared to 12.04. My laptop sees also less wifi-networks than before.

The problem exist with the build-in wifi adapter. I used also another usb wifi adapter and it was as slow as the build in (though the reception was better as the antenna is huge). Then I activated the usb-tethering of my smartphone, plugged it to the laptop and checked the connection, it was as fast as it used to be. So it seems to be wifi related, but not related with networking in general.

ifconfig wlan0

wlan0     Link encap:Ethernet  HWaddr 00:08:ca:e6:76:d8  
          inet addr:192.168.178.51  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: fe80::208:caff:fee6:76d8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2653 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3198 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1526256 (1.5 MB)  TX bytes:382403 (382.4 KB)

iwconfig wlan0

wlan0     IEEE 802.11bgn  ESSID:"xxxxxxx"  
          Mode:Managed  Frequency:2.472 GHz  Access Point: 00:1C:4A:47:CB:29   
          Bit Rate=27 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=23/70  Signal level=-87 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:12  Invalid misc:43   Missed beacon:0

route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.178.1   0.0.0.0         UG    0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.178.0   0.0.0.0         255.255.255.0   U     9      0        0 wlan0

I have experimented with the following commands (http://www.unixmen.com/resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal/) but they seem not to work anymore as i received either errors or no effect.

share|improve this question
add comment

1 Answer

Try http://linuxg.net/fix-the-slow-connection-problem-when-using-wifi-on-ubuntu-13-04-12-04-or-linux-mint-13/ I have tried solutions 1 and 3, 2 comes back with no such file found.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.