Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

IIRC, once upon I time I used only the mouse for copy-and-paste, which I consider way superior to the Windows-like Ctrl-C Ctrl-V complication. Now after many years I'm slowly starting to use Linux again and to my horror I see that it doesn't work anymore, except between Emacs and terminal windows. Of course, the keyboard shortcuts don't work in Emacs, so it's a real pain e.g. to copy from Emacs to Firefox.

Is there a way how to fix it? I mean I want to use marking and pasting using the mouse only everywhere, not the other way round.

I'm not asking about clipboard managers, I need neither clipboard persistence nor multiple clipboards, but if it solves my problem, I'll go for it.

share|improve this question
I'm not sure what you have done with your specific set up, but this still works in everything I've just tried. – Ward Muylaert Mar 13 '11 at 11:57
@Ward I'm using quite a new installation and did about nothing yet. I've marked a line in Emacs using a triple click, switched to Firefox, pressed the middle mouse button and nothing happened. – maaartinus Mar 13 '11 at 12:09
Now it works... I noticed my middle mouse button doesn't work sometimes... it must have been the reason. Sorry for the noise. – maaartinus Mar 14 '11 at 10:29
up vote 1 down vote accepted

Using the mouse

Kubuntu comes with a clipboard manager by default, Klipper.

Ubuntu has a simple clipboard manager (not installed by default) that does contains everything you want: no persistence and copy on select (configurable). It's called Parcellite. You need to enable "Use Primary (Selection)" to enable copy-on-select.

Parcellite Preferences

Both applications can be configured to (not) save the clipboard on shutdown.

Using the keyboard

In the terminal, Ctrl + C sends a SIGINT kill signal to applications.

The default shortcuts in the Terminal are:

  • Copy: Ctrl + Shift + C
  • Paste: Ctrl + Shift + V

These shortcuts can be customized in the Terminal application itself.

share|improve this answer
Sorry, I see question wasn't clear enough. I don't want to use keyboard at all (when holding the mouse already). – maaartinus Mar 13 '11 at 11:49
@maartinus: updated, I'll add screenshots soon. – Lekensteyn Mar 13 '11 at 12:13
Thank you, I'll try it. – maaartinus Mar 13 '11 at 12:59

In X you just have to mark the text you want to have copied and use the middle mouse button to paste it wherever you want.

share|improve this answer
This doesn't work e.g. for the URL in Firefox. I've tried it several times. – maaartinus Mar 13 '11 at 11:47
This is strange. Me and someone else tested this on 10.10 using Firefox 3.6.15 and 4 RC1. Both times it worked. – Octavian Damiean Mar 13 '11 at 13:56
@maaartinus When you try pasting a URL into Firefox, how are you clearing the address bar first? I can select text in GNOME Terminal and then paste it into Firefox's address bar using the middle mouse button (and vice versa), but I don't know of a quick way to clear the address bar prior to pasting that doesn't involve selecting the current URL — an action that would overwrite my clipboard contents. – ændrük Mar 13 '11 at 14:34
@ændrük The only workaround I know is to open a new tab instead of working in the same tab. – Octavian Damiean Mar 13 '11 at 14:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.