Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Ubuntu 13.04 (the 64-bit Mac variant) onto my Mac Mini. Thus I shrunk the main MacOSX partition and installed refind. Now I can boot into rEFInd and then select the usb stick, but it does not boot due to:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Sadly I cannot find anyone who tried a recent Mac Mini/Ubuntu version. How best to debug this issue?


Update 1:

So I figured maybe rEFInd does not provide the necessary driver and installed it again via install.sh --drivers-all. Which lead to a WSOD. Luckily I eventually could get back into restore via Command + R and am now reinstalling MacOSX.


Update 2:

After my MacOSX was working again I did:

  • installed _rEFIt
  • set up my future Ubuntu partition as FAT
  • booted twice
  • booted into Ubuntu Live CD

And that's where the next trouble started. While wireless and graphics work great in Ubuntu 13.04, they mount the FAT partition as /cdrom, which makes installing on it impossible.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Why not try rEFIt instead ?

check out http://mabelmzhang.blogspot.com/2013/02/how-to-guide-for-triple-booting-mac-os.html

rEFIT / Ubuntu 12.04 LTS / Kernel 3.9.x worked for me

share|improve this answer
1  
rEFIt seems no longer maintained!? You are talking about a recent Mac Mini with Mountain Lion installed? –  abergmeier May 30 '13 at 6:38
    
correct. rEFIt is no maintatined. but it's MAC friendly and works. –  RamG May 30 '13 at 7:31
    
I am still missing the Mac Mini model you installed on. –  abergmeier May 30 '13 at 7:36
    
I got MacMini 6.2 now with triple boot set up for OSX 10.8.3, Ubuntu 12.04 LTS (Kernel 3.9.x) and Windows 7 based on link mabelmzhang.blogspot.com/2013/02/… –  RamG May 30 '13 at 7:45
    
I got the late 2012 Mac Mini 6,2 model with the i7 processor running OSX Mountain Lion. This one => store.apple.com/us/configure/MD388LL/A?#hardware –  RamG May 30 '13 at 7:59
  • Kernel 3.5.x appears to have issues enabling Wired Ethernet Connection on Mac Mini 2012. Upgrade to Kernel 3.9.x fixed the issue.

  • Also had low color issue with HDMI graphics. work-around: 'sudo pm-suspend'

share|improve this answer

This is a somewhat complete guide that I wrote to help you all brave tux users to make the whole Ubuntu/Linux mint installation process a breeze. I try to address all the issues I had with wireless broadcom drivers and power management.

Have a read and post comments if something is not right with the document..

https://theredblacktree.wordpress.com/2013/09/07/installation-guide-for-linux-mint-15-ubuntu-13-04-on-apple-mac-mini-late-2012/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.