Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble updating Firefox, it does not update from the terminal and doesn't show up in the update manager. I'm running Ubuntu 12.04.

If I run apt-get install firefox it claims that the latest version is already installed and if I run firefox -v I get that Mozilla Firefox is version 6.0.2.

How can I solve this problem?

I don't want to manually download and upgrade firefox with archives and move and deleting folders every time a new version I released.

Update:

The output of sudo apt-get update is here.

share|improve this question
1  
What's your Ubuntu version? Did you run apt-get update before apt-get install firefox? –  Eric Carvalho May 29 '13 at 17:04
1  
No problemo: paste.ubuntu.com/5714487 –  Axel May 29 '13 at 19:44
3  
@Axel: What's the output of which firefox and cat "$(which firefox)"? Perhaps you installed a second copy of Firefox from outside the package manager, which is taking precedence. –  Mechanical snail May 29 '13 at 20:22
3  
If you do apt-cache policy firefox what is the result? –  Braiam Aug 14 '13 at 0:13
1  
Why are there maverick lines in your source list? –  xangua Feb 20 at 19:11

1 Answer 1

Looking at the output of your sudo apt-get update command, it seems like you have a broken /etc/apt/sources.list file. To fix this, open Software sources by typing "software sources" in your dash and then check if there is a tick on the following:

  • Canonical-supported free and open-source software (main)
  • Community-maintained free and open-source software (universe)
  • Software restricted by copyright or legal issues (multiverse)

and the download takes place from the server nearest to you("Main Server" is fine for the moment but it may be busy at times).

And then open a terminal(Ctrl+Alt+t) and type the following:

 sudo apt-get update
 sudo apt-get install firefox

You should have the latest version of firefox now.

share|improve this answer
    
There's a 404 but that wouldn't stop it working (it's a warning not an error). The rest of the sources look legit. –  Oli Feb 20 at 22:48
    
@Oli: He has maverick in his /etc/apt/sources.list! –  i08in Feb 21 at 3:34
    
I see that and I agree it's weird but technically irrelevant here because there's also precise-security/main i386 Packages which contains the latest version of firefox. Neither the maverick lines (nor the 404 warnings) could stop apt picking the latest version of Firefox. –  Oli Feb 21 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.