Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having upgraded to 12.04 (LTS!) desktop only shows a simulated keyboard (later on I learned that its keys are [dis]functional in parallel the real ones) and 2 icons (links) inherited from 10.04, the useful one is to gedit.

There was a similar question (Questions for Ubuntu Question: 12.04 "main menu") and answer (Warren Hill ...Open up a terminal by pressing CTRL + ALT + T then enter the following command

sudo apt-get install gnome-panel

Next time you log in click on the Ubuntu logo and select Classic...) - I cannot find them any more.

  1. As an example, ctrl+alt+t had no effect on both keyboards.
  2. I learned to open a terminal via a menu of gedit - but could not enter anything.
  3. In case I succeed: Does apt-get install from disk or internet? I cannot verify being online.
  4. gedit allows to view folders via open ... cancel. Inserting a usb stick opens nautilus, but windows have no no title-bar with icons to size, close, or move.
  5. Right-clicking on desktop gets me into cofiguration (no way back but shut-down via the dedicated real key - in spite of the popup-exit-menu a disk check is enforced after next boot). Selecting my (real) german keyboard did not bring back its functionality... I am locked up.
  6. Can I re-install 10.04? (I have a left-over bootable image on a usb stick and hope it works). However, if I lose all my additional packages with configs and data from 10.04, I will give up and reformat the partition to windows. How can I remove grub?

As I cannot use my own pc, be prepared for elongated response time. This is my 1st encounter with askubuntu, I tried a few of the similar questions: most of them had a working keyboard, so I will try my stick as a live-cd, but do not know what to do or to look for, and askubuntu will not be at hand. Another answer suggests to boot a former kernel, I will try. As I remember, all recovery lines (including windows) from grub menu are gone.

Amendment by the author - in hope that this is the expected way to close this question: There was no answer on askubuntu during some 3 weeks, but I found an aide at ubuntuusers.de and would like to submit the partial solution as it stands.

All reported problems seem to originate from my user account which was somehow corrupted by the upgrade process. I cannot explain that or give you details, but the found solution may serve as a proof thereof. a. As reported in topic 5, a new (admin) account could be created and - using real keys to enter and re-exit standby - activated via login (Fortunately, the keyboard worked during these activities!). b. Lo an behold! Starter, panel, etc. were in place and working. Conversely, the old account is still inoperative. c. A lot of work and related questions remain, as I have to transfer all my ordinary and autostart apps and applets to the new account, check them and their configuration for function and compatibility, adapt menues and links - and NOT re-introduce any of the destructive effects. There will be many and manifold problems and I cannot anticipate them now. Maybe there are some solutions in askubuntu.

I am not an expert user and hope to find further help and advice when I try all this piece by piece. When I decided to UPGRADE to 12.04 lts I had hoped to avoid such a life-task in the first place. In that sense, the plan to adapt ubuntu for smart-phones and whatever may be the end of long time support, even with 12.04. I regret that, but that's life. Thank you.

share|improve this question
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.