Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After having some bouts with windows 8 I decided to throw it out and run Ubuntu as the main operating system.

Currently I am having some problems with performance:

Even when running the simplest tasks, such as logging in to the UI or console, or running apt-get upgrade, it takes a very long time, and the CPU fan is spinning at full speed. I run top, and the top application itself takes about 13%. As a comparison, if I run top on a 2007 Macmini also running Ubuntu 13.04, top uses about 0,5%. Cold-boot to login-prompt GUI takes minutes, compared to about 15 seconds on Windows 7 and less than a minute on the Macmini. Starting a terminal window by ctrl-alt-t takes perhaps 20 seconds, and even editing a command line has significant delays.

Question: How do I solve this performance problem?

I have installed Ubuntu 13.04 (64 bit) on an Acer Aspire 8951G on the 120 GB SSD in ext4 format, with a 32 GB swap on an HDD. Then, coming from a Windows environment, I started by doing an update: sudo apt-get update && apt-get upgrade. It also was very slow. I have 32 GB RAM installed (which works in the BIOS, Windows in Ubuntu). I have the most current BIOS (1.13) I could find on the Acer support site.

If I start partedmagic from the current ultimate boot cd, there is the same performance problem. If I try the partedmagic on another Acer I have (Acer Aspire V3-571G), there is the same performance problem. In Windows 7 that I had installed yesterday as the main operating system, there were no performance problems.

I tried hardinfo with results hardinfo. /var/log/syslog contains /var/log/syslog

More info 2013-05-30:

I tried Ubuntu Live USB-Stick 13.04 x86_64 on my:

Acer V3-571G (the one that was slow earlier with partedmagic) with the following hardinfo. Ubuntu was very responsive and I was happy with the performance on that computer. Here is the /var/log/syslog.

Acer Aspire 8951G (my problem-computer) with the resulting /var/log/syslog contents. I selected to try ubuntu from the stick. The system did not even get to the login screen before I gave up.

An interesting part from the end of the problem-syslog: timeout: killing 'keymap input/event, ------ rcu_sched self-detected stall on CPU, ------ BUG: soft lockup - CPU#3 stuck for 22s!

A memory test using Memtest86+ for several hours (1 iteration) passed ok.

I tried installing bumblebee and its suggested dependencies with no noticeable change in performance.

sudo powertop --time=60 --html produces the report PowerTop.html

Edit 2013-06-06:

grep Graphics /var/log/Xorg.0.log and cat /var/log/Xorg.0.log results are at paste.ubuntu.com

i cat /proc/cpuinfo | grep "cpu MHz" and cat /proc/cpuinfo results are also at paste.ubuntu.com

share|improve this question
    
That BUG: Soft lockup seems to be bug.. Tried to boot with mainline kernel to see if that works? wiki.ubuntu.com/Kernel/MainlineBuilds –  aXept May 31 '13 at 12:03
    
What is the bug number? –  coteyr Jun 1 '13 at 6:47
    
@dontomaso can you run cat /proc/cpuinfo | grep "cpu MHz" –  coteyr Jun 1 '13 at 6:48
    
I would have put it into note but cant. Sent us your grep "Graphics" /var/log/Xorg.0.log if it Desn't show any driver just send hole file. I think it is connected with few more issues (and bug I have reported) Try installing from DVD –  Tomas Jun 2 '13 at 16:18
    
Run an internal/bios diagnosis, see if everything is well. Is there any recent history of windows crash? –  22lk94k943 only Jun 2 '13 at 16:42
show 1 more comment

3 Answers

I think you could have too much SWAP ram configured. At a certain point, more SWAP ram slows down the computer considerably. Maybe try keeping the RAM+SWAP to a reasonable level (not 64GB), except if you really need it. A good alternative would be to change the Swappiness (how much the computer uses SWAP) to a lower level. The following command checks your swappiness.

cat /proc/sys/vm/swappiness

Swapiness is default at 60, meaning it will use your slow hard drive instead of your probably ultra fast ram 60% of the time. You can modify the swappiness with the next command, you will have to try around with the value a bit, maybe even set it to 0 (32 gigs ram is plenty really):

sudo sysctl vm.swappiness=[enter value here]

However this works only for the current session. To change the swappiness on startup (when it really matters), you will have to edit a config file

gksudo gedit /etc/sysctl.conf

Find the vm.swappiness line; if none exists, add it.

vm.swappiness = [enter value here]

to use the settings without rebooting, toggle swapping

  sudo swapoff -a; sudo swapon -a

I hope this helped, please leave some feedback ;)

scource: http://www.n00bsonubuntu.net/content/change-swappiness-settings/

share|improve this answer
add comment

For the SSD make sure its firmware is up to date. Also check and see if you can get a driver for the nVidia card, sometimes that makes all the difference in the world.

You can also run an alignment tool in Windows to make sure the SSD is properly aligned.

If you disable journaling for EXT4 that can help improve speed as that's been the cause for issues with SSDs and Ubuntu 12.10 in the past.

To disable journaling for ext4 do the following:

  1. Unmount the filesystem, you may need to do this from a bootable DVD or USB drive (preferred)
  2. Run the following in a terminal windows: tune4fs -O ^has_journal /dev/sda1

  3. Run from terminal: e4fsck –f /dev/sda1

Just reboot afterwards. NOTE: DISABLING JOURNALING CAN CAUSE DATA LOSS IN AN EVENT OF A POWER OUTAGE!

share|improve this answer
add comment

You might also want to delete the partition completely using gparted (using puppy linux of which most if not all have gparted, or use gparted live pendrive/cd or using the live UBUNTU CD if you have an internet connection and install gparted) and recreate it, making sure that "align to MB" is chosen and create an EXT4 partition in the empty space.

It is possible that the installer did not align the partition to MB as what happened to me and the machine was deadly slow. Once i did this, my machine flew.

share|improve this answer
add comment

protected by Community Jul 6 '13 at 20:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.