Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing recommended libraries I am still unable to play any DVD. I am able to play CDs just fine but when I insert a DVD, I get this error: "Unable to mount (DVD NAME) Error creating moint point: No such file or directory." If I manually mount my cdrom with sudo mount /dev/sr0 /cdrom I can access the VIDEO_TS file but am still unable to actually play the DVD itself.

sudo lshw output:

     *-scsi:2
      physical id: 3
      logical name: scsi2
      capabilities: emulated
    *-cdrom
         description: DVD-RAM writer
         product: DVDRAM GH24NS90
         vendor: HL-DT-ST
         physical id: 0.0.0
         bus info: scsi@2:0.0.0
         logical name: /dev/cdrom
         logical name: /dev/cdrw
         logical name: /dev/dvd
         logical name: /dev/dvdrw
         logical name: /dev/sr0
         version: IN01
         capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
         configuration: ansiversion=5 status=ready
       *-medium
            physical id: 0
            logical name: /dev/cdrom
share|improve this question
add comment

2 Answers

I finally found the fix. I was missing /media/cdrom. I am not sure why it was never created in the first place but it is working now :D

share|improve this answer
    
I recommend accepting your own answer (since it's what solved the problem) by clicking the green check mark to the left of it. –  Eliah Kagan Aug 30 '13 at 14:28
add comment

You need to set up to decode the copy protection on DVD's in order to play them....

sudo apt-get install ubuntu-restricted-extras
sudo /usr/share/doc/libdvdread4/install-css.sh
share|improve this answer
    
I have already done this with the same result. Still gives me the same error saying the mount point does not exist. –  user162655 May 29 '13 at 17:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.