Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed the updates on my XUbuntu system, and now thunar is crashing with the following message:

thunar: symbol lookup error: thunar: undefined symbol: exo_icon_view_selection_invert

The dpkg -s output of thunar is as follows:

Package: thunar
Status: install ok installed
Priority: optional
Section: xfce
Installed-Size: 890
Maintainer: Xubuntu Developers <xubuntu-devel@lists.ubuntu.com>
Architecture: amd64
Version: 1.6.2-0ubuntu1~ppa0.12.04.1
Replaces: thunar-data (<< 1.2.3-3)
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.4), libcairo2 (>= 1.6.0), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.88), libexo-1-0 (>= 0.9.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk2.0-0 (>= 2.24.0), libgudev-1.0-0 (>= 147), libice6 (>= 1:1.0.0), libnotify4 (>= 0.7.0), libpango1.0-0 (>= 1.14.0), libsm6, libthunarx-2-0 (>= 1.1.0), libxfce4ui-1-0 (>= 4.9.0), libxfce4util6 (>= 4.9.0), libxfconf-0-2 (>= 4.6.0), thunar-data (= 1.6.2-0ubuntu1~ppa0.12.04.1), desktop-file-utils, shared-mime-info, exo-utils
Recommends: dbus-x11, xfce4-panel (>= 4.9.2), thunar-volman, tumbler, xdg-user-dirs, gvfs
Suggests: thunar-archive-plugin, thunar-media-tags-plugin
Breaks: thunar-data (<< 1.2.3-3)
Description: File Manager for Xfce
 Thunar is the file manager designed to be the default file manager of Xfce 4.6
 It has been designed to be fast and easy to use.
 .
 An Xfce plugin can manages the trash, if xfce4-panel is installed as well.
 Please read README.Debian for volume management stuff.
Homepage: http://thunar.xfce.org
Original-Maintainer: Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>

How do I go about fixing this?

share|improve this question
    
When you use the Xfce 4.12 ppa with Thunar 1.6.2, you must also have installed the Xfce 4.10 ppa if running Xubuntu 12.04. However, this error seems to be related to libexo: what is the output of ldd /usr/bin/thunar? –  user76204 May 29 '13 at 17:11
    
@Mik yes the version of my xfce4-session is 4.10.1-0ubuntu1~ppa0.12.04.1 And the output of ldd /usr/bin/thunar is at pastebin.com/frxQ0z0Y –  Midhat May 29 '13 at 17:54
    
The output of ldd looks fine for your system- i.e. the right versions of the libraries are being called. It could be an issue on 64 bit systems, as I can't replicate it on my 32 bit system. If we can't find a solution, you may need to file a bug upstream at xfce.org. –  user76204 May 29 '13 at 18:26
    
The problem was that I did a manual build of xfce some time ago, and messed up the library paths. See forum.xfce.org/viewtopic.php?pid=29965 –  Midhat Jun 6 '13 at 8:42
    
Please put this last comment into an answer, and then accept it as seems to solve your problem. –  landroni Jan 15 at 21:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.