Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hey, how would I go about controlling my graphics card's fan speed (XFX HD 5770)? For some reason it keeps spinning up and it's really loud. I currently dual boot with Windows 7 x64 and it works fine on that and remains at a steady speed. I have tried using lm-sensors but I can't seem to get it to work.

share|improve this question

closed as too localized by Bruno Pereira, Marco Ceppi Feb 8 '12 at 12:27

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
are you using the open source driver or the fglrx driver (catalyst)? I actually have the same question but specifically for the open source radeon driver. I have not figured it out yet –  Matt Wolfe Dec 15 '11 at 19:20
    
This question seems abandoned, there is not further information or activity added to it for several months. I am flagging this to be closed by a moderator. If you think this issue is still affecting you you can flag a moderator to re-open it. –  Bruno Pereira Feb 8 '12 at 10:52
add comment

2 Answers 2

There is a setting in the Catalyst options but you will have to unlock the lock though. I was able to see that on Windows but I don't see that in Ubuntu.

share|improve this answer
    
The windows and ubuntu radeon drivers are quite different and provide different functionality. Maybe the catalyst settings window look a bit similar, but you can easily note, that the options available are different. And, of course, the driver itself works in a different way. This means that it is possible, that some settings that you have seen on windows simply do not exist on Ubuntu. Blame ATI :( –  Rafał Cieślak Jul 12 '11 at 16:21
add comment

next, will set your fan to 30% speed:

aticonfig --pplib-cmd "set fanspeed 0 30"

if reqired, run this before:

sudo aticonfig –initial -f
share|improve this answer
    
I think it doesn't work for me. Just says: PPLIB command execution has failed! ati_pplib_cmd: execute "set" failed! –  Rafał Cieślak Jul 12 '11 at 16:21
add comment