Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 13.04. Before this when I click on a shell script file it'll give an option to run via terminal but now the option is no longer available and when I click the file it'll directly open via gedit.

How to run it via terminal and if possible, make it like that on default?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Open the file explorer Files. Press Alt+F10 and select Preferences. You should see something like this.

In the Behavior tab, select Ask each time and close it. Now double on a shell script will ask you what to do each time. If you want to straight away execute the script, select the first option Run executable text files when they are opened.

enter image description here

share|improve this answer
    
Thanks a lot!!! –  Dania May 28 '13 at 7:29
add comment

Open up a terminal and change to the dir that the script is in and type

./scriptname

share|improve this answer
add comment

protected by Community Jun 22 '13 at 6:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.