Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install the AMD Catalyst version 13.1 driver on Ubuntu 12.04 LTS (desktop version).

I have downloaded the *.run file corresponding to the driver version.

I am following the instructions to install Catalyst here:

All the dependencies were downloaded as well.

When I run:

It fails to build the package with the error:

Generating package: Ubuntu/precise
Package build failed!
Package build utility output:
./packages/Ubuntu/ 294: ./packages/Ubuntu/ debclean: not found
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2

I downloaded devscripts as well to fix the error related to debclean.

sudo apt-get install devscripts

Reading package lists... Done
Building dependency tree       
Reading state information... Done
devscripts is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 189 not upgraded.

As you can see, I have the latest version of debclean installed. Even after this, it fails to build the package when I run with the same error specific to "debclean not found". How can I fix this error?

sudo sh --buildpkg Ubuntu/precise


share|improve this question
Try running debclean in a terminal, and possibly: sudo apt-get install debclean (not sure if that package exists, but it follows package name convention) – Yet Another User May 27 '13 at 18:05
There is no package with the name, debclean. From what I have read on various internet resources, in order to install debclean, we need to install devscripts using apt-get. However, I am not sure why even after install devscripts, the error for debclean persists. – Neon Flash May 27 '13 at 18:41
Looks like it's in the devscripts package, indeed. – Yet Another User May 27 '13 at 20:33
Before running the ati installer, do: sudo apt-get install debhelper dh-modaliases execstack – user285536 May 26 '14 at 18:53

Just try this link. It may help. At least it will guide you how to cover the problem.


P.S.: I have ATI Mobility Radeon HD 4xxx series and it worked for my cause.

share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – fossfreedom Jun 12 '13 at 13:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.