Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I am currently using 12.04 and have a GTX 580M, when I go to check the drivers it says that I dont have any proprietary drivers currently installed, so I am unable to download any newer ones (obviously.)

My problem is that I have been told that I will need to install the newest drivers in order for playonlinux etc. When I try and install the .run file direct from the Nvidia site it says that I need to close X Server first, however when I go into X Server it says

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server."

I have tried this in terminal and get this message

"Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
                  Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as
'/etc/X11/xorg.conf.nvidia-xconfig-original'
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

Does anyone know how I can go about getting this to work?

EDIT: I have tried stopping X Server through terminal and all this does is close the GUI, it still wont allow me to apply the drivers

share|improve this question
add comment

1 Answer

As mentioned here in this blog post,

After executing sudo nvidia-xconfig, you need to enable additional drivers.

Execute sudo software-properties-gtk which will open up a window like this

enter image description here

Select the latest driver and then reboot your machine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.