Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't get webmin installed on my Ubuntu 12.04 lts server.

I get the following error:

/var/lib/dpkg/info/webmin.postinst: 58: /var/lib/dpkg/info/webmin.postinst: cannot create /etc/webmin/uninstall.sh: Directory nonexistent

chmod: kan geen toegang krijgen tot â/etc/webmin/uninstall.shâ: Bestand of map bestaat niet
grep: /etc/webmin/miniserv.conf: Bestand of map bestaat niet

What am I doing wrong?

I just follow the guide lines from webmin. I even tried to install an older version 1.580, but I get the same error.

I am logged in through putty and as root ...

share|improve this question
    
If you are installing Webmin from the command line (recommended) try apt-get -f install –  douggro May 27 '13 at 17:20
    
Hi i tried it already, but that doesn't work ... I still get the same error. Any other suggestions? –  Ronny May 27 '13 at 18:52
    
Are you actually logged in as root or are you using sudo privileges? I would not try to install Webmin when logged in as root as this can cause some unexpected issues with Ubuntu. You could also try using the Debian installation method which is, IIRC, the method I used. –  douggro May 28 '13 at 4:07
    
I tried both ways ... the wget http://prdownloads.sourceforge.net/webadmin/webmin_1.630_all.deb & dpkg --install webmin_1.630_all.deb but also with using the Webmin APT repository. Both ways i get the same error ... am am logged in as root ... –  Ronny May 28 '13 at 7:56
    
I still believe your problems are related to installing when logged in as root. I would use a normal admin account and install using sudo privileges if necessary. –  douggro May 28 '13 at 16:45
show 4 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.