Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title says, my laptop is a HP dv6 7040tx which has the following dual graphics cards:

1.Intel 4000

2.Nvidia 630M

I went through some sites and found that both my graphics card are being used. So, it was recommended for me to install Bumblebee.

I installed it and I used optirun to run my games. But, now my laptop is heating up! I was copying files over LAN and I'm downloading torrent files. There is not much CPU usage. It stays at around 5%. But, the sensor values read as follows:

acpitz-virtual-0
Adapter: Virtual device
temp1:        +86.0°C  
temp2:        +86.0°C  (crit = +120.0°C)
temp3:        +30.0°C  (crit = +120.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +86.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +86.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +86.0°C  (high = +87.0°C, crit = +105.0°C)
Core 2:         +81.0°C  (high = +87.0°C, crit = +105.0°C)
Core 3:         +81.0°C  (high = +87.0°C, crit = +105.0°C)

Is there a s/w to control this or should I do something else?

share|improve this question
add comment

2 Answers 2

The answer to Overheating problems and power consumption on laptops is the following:

This is a guide for Hybrid laptops and the codes are for Terminal (I recommend at least Ubuntu 13.10).

For AMD/Intel , run this command in the terminal (uninstall other drivers first):

sudo apt-get install fglrx fglrx-pxpress

Then: sudo amdcccle and set the graphics to intel graphics :)

For Nvidia (uninstall any other driver first):

sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime

For laptops:

TLP helps laptop reduce the ammount of power consumed in a much more efficient way than any other:

First: Uninstall laptop mode tools

sudo apt-get remove laptop-mode-tools

Then install:

sudo add-apt-repository ppa:linrunner/tlp sudo apt-get update sudo apt-get install tlp tlp-rdw

Finally start it:

sudo tlp start

With this, you will fix your broken packages that overheat Ubuntu and you will have about 2 hour extended battery life.

share|improve this answer
    
Don't duplicate the same answer across multiple questions. If the questions need the same answer, then likely there are duplicates among them that need to be flagged. You end up giving all community reviewers more to do. The duplicate answers have been removed. –  fossfreedom Jan 7 at 23:01
add comment

Yes there is an ugly hack, which needs to be in place so that it shuts down your discrete graphics card on boot and will disable it on Ubuntu. Which I think should be fine as it will totally chill your system

Step 1. goto terminal (alt+ctrl+t) and type:

sudo gedit /etc/rc.local

Step 2. add the following lines before exit 0:

echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

So your rc.local would look something like this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

exit 0

Step 3: Save and exit gedit, then type:

sudo reboot

Enter your password when required.

Basically what you did was, you switched to Integrated (IGD) graphics. Then switched off the other one.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.