Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get the following error message

The following packages have unmet dependencies:
 fuse-utils : Depends: libfuse2 (= 2.8.4-1.3) but 2.9.2-4 is installed
 gvfs : Depends: gvfs-daemons (>= 1.16.2-2) but it is not installed
        Depends: gvfs-daemons (< 1.16.2-2.1~) but it is not installed
        Depends: gvfs-libs (= 1.16.2-2) but it is not installed
 gvfs-backends : Depends: gvfs (= 1.6.1-0ubuntu1build1) but 1.16.2-2 is installed
 libfuse-dev : Depends: libfuse2 (= 2.8.4-1.3) but 2.9.2-4 is installed
 python-apt : Depends: python (>= 2.7) but 2.6.6-13 is installed

I haven't got a clue how to proceed. Simply removing these packages creates a cascade of pain.

This was marked as a duplicate. I'm pretty sure I tried all of those suggestions. Making forward progress seems to require identifying what package to remove. Removing gvfs, gvfs-backends, libfuse-dev, python-apt all lead to cascading problems.

  1. Under Ubuntu Software tab, enable all the repositories. -- this is a headless server, there is no GUI
  2. sudo apt-get clean -- doesn't help
  3. sudo apt-get -f install -- doesn't help
  4. sudo dpkg --configure -a Then run this again:

    sudo apt-get -f install

    doesn't help

  5. sudo apt-get -u dist-upgrade -- doesn't help
  6. sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade

    --- E: Unmet dependencies. Try using -f.

  7. Disabling a PPA means no more updates for the packages installed from that PPA. To disable a PPA: Open Software Center > Edit > Software Sources Or,

    -- again headless server, no gui

  8. sudo apt-get install ppa-purge -- won't run because of existing errors

I'm looking for new suggestions. The standard one's aren't working.

My /etc/apt/sources.list.

share|improve this question
visit :… – obysr May 26 '13 at 21:24
Can you upload your /etc/apt/sources.list as well as all the '*.list' files inside /etc/apt/sources.list.d/ to and include the links in your question? – Eric Carvalho May 27 '13 at 10:52 – Geoffrey May 27 '13 at 12:01

This is in your sources.list:

deb unstable main
deb-src unstable main
deb experimental main
deb-src experimental main

You added a Debian repository to Ubuntu. Probably you broke your system very badly.

Adding Debian Sid as Package Repository?

You could try removing those lines, then run:

sudo apt-get update
sudo apt-get dist-upgrade

Also, if aptitude is installed, run sudo aptitude and look under "Obsolete and Locally Created Packages". Write down these "obsolete" (packages that doesn't exist in repos) and run:

sudo aptitude reinstall <list of packages>

That list of packages can also be found in synaptic, clicking the "Origin" button then selecting "Local".

But I really think you'll have to reinstall Ubuntu.

share|improve this answer

I had a similar problem, which i solved by downgrading libfuse so it matched the version libfuse-dev required. For this question it would be:

sudo apt-get install libfuse2=2.8.4-1.3

after that fuse-utils and libfuse-dev should install OK.

the gvfs and python problems are probably to do with using mixed debian and ubuntu repositories - but specifying a version might force apt to get it from the correct repo, which might solve the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.