I get the following error message
The following packages have unmet dependencies: fuse-utils : Depends: libfuse2 (= 2.8.4-1.3) but 2.9.2-4 is installed gvfs : Depends: gvfs-daemons (>= 1.16.2-2) but it is not installed Depends: gvfs-daemons (< 1.16.2-2.1~) but it is not installed Depends: gvfs-libs (= 1.16.2-2) but it is not installed gvfs-backends : Depends: gvfs (= 1.6.1-0ubuntu1build1) but 1.16.2-2 is installed libfuse-dev : Depends: libfuse2 (= 2.8.4-1.3) but 2.9.2-4 is installed python-apt : Depends: python (>= 2.7) but 2.6.6-13 is installed
I haven't got a clue how to proceed. Simply removing these packages creates a cascade of pain.
This was marked as a duplicate. I'm pretty sure I tried all of those suggestions. Making forward progress seems to require identifying what package to remove. Removing gvfs, gvfs-backends, libfuse-dev, python-apt all lead to cascading problems.
- Under Ubuntu Software tab, enable all the repositories. -- this is a headless server, there is no GUI
sudo apt-get clean-- doesn't help
sudo apt-get -f install-- doesn't help
sudo dpkg --configure -aThen run this again:
sudo apt-get -f install
sudo apt-get -u dist-upgrade-- doesn't help
sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade
--- E: Unmet dependencies. Try using -f.
Disabling a PPA means no more updates for the packages installed from that PPA. To disable a PPA: Open Software Center > Edit > Software Sources Or,
-- again headless server, no gui
sudo apt-get install ppa-purge-- won't run because of existing errors
I'm looking for new suggestions. The standard one's aren't working.