Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When booting 13.04 to the 3.5.0 kernel that came with 12.10, the NVidia drivers seem to be playing up. Screen resolution is not what it should be, and I can't set it to the correct resolution either. The "NVidia X server settings" tool gives the following error dialog:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

However, running nvidia-xconfig as root doesn't fix it. I tried both NVidia's 310 driver (which works on the default kernel) and the 304 driver (which used to work on 3.5, ubuntu 12.10), but no dice. GPU is an NVidia Quadro FX570M.

The reason I'm booting to the old kernel is that I'm encountering what appear to be processor scaling issues with the 3.8 (and 3.9) kernels, which I don't remember from the 3.5 kernel - which is why I want to try it out.

EDIT: The Nouveau driver seems to be having troubles as well now, reverting to 640 x 480 resolution on both the 3.5 and 3.9 kernels. Something's seriously messed up, isn't it?

share|improve this question
up vote 0 down vote accepted

You'd have to have the linux headers from your kernel installed. For 13.04 the linux-headers-3.5.0-... is not in the official repositories, so you'll have to get it elsewhere.

With any nvidia issues, it's best to purge all installed drivers and try to reinstall them. sudo apt-get purge nvidia*and then sudo apt-get install nvidia-304 when you're running the kernel you want them to run on.

If this doesn't work, you'd have to purge them again and build the nvidia kernel module from source, when running this kernel. Notice that it's not installed with a package, so when you want to remove these modules again when you plan on updating the kernel, you'd have to run the nvidia specific removal tool.

share|improve this answer
I installed the 3.5.0 kernel headers from the Quantal repo, but the nvidia driver refused to install with those: "Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed". But while trying this, I noticed that the Nouveau drivers seem to have the same problem - so perhaps it's not specific to the nvidia drivers? Updating the original post to reflect. – Bernard May 27 '13 at 19:34
Have you tried building them from source? Basicly download the version you want (pref 304 or something), untar it and run sh ./ To uninstall when you want rid of it (if it's not working you need to do sh ./ --uninstallor something. I think it also need to be run from tty1 (CTRL-ALT-F1) Best to google it a bit more – labsin May 27 '13 at 22:31
Well, turns out that just installing 3.7.0-030500 headers wasn't enough - evidently, they didn't match the 3.5.0-27 kernel I was running, which is why sudo apt-get install nvidia-304 failed to install the drivers. I installed the kernel image to match the headers, and now graphics are working again - both on the 3.5 and 3.9 kernels. – Bernard May 30 '13 at 19:38
@Bernard: If you install a new kernel, be sure to install: linux-headers-3.x.y-generic (i386 or x64) linux-headers-3.x.y linux-image-3.x.y-generic (i386 or x64) linux-image-extra-3.x.y-generic (i386 or x64) For the upstream release, you just need to install linux-generic. This is a virtual package which depend on the latest releases. – labsin May 30 '13 at 20:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.