Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've asked for help on the Steam discussion boards and on the Steam Github bug page and I was told to ask about this issue on an Ubuntu forum. Here are the links:

https://github.com/ValveSoftware/steam-for-linux/issues/2516

http://steamcommunity.com/app/221410/discussions/5/828939797039531960/

Anyways, I compiled a custom 3.7.9 kernel a long time ago because I was having issues with my laptop (closing the lid made the screen permanently black, keyboard didn't light up, no hibernation, etc). The 3.7.9 kernel fixed all of these issues and everything has been running a whole lot smoother ever since.

Unfortunately, the Nvidia drivers from Jockey did not work. I don't remember the reason; it was a long time ago. I downloaded and installed the 310.32 driver manually from Nvidia's website. I had to manually patch the installer because my kernel was too new, but other than that everything seems to have installed fine.

tail -n 21 /var/log/nvidia-installer.log

-> Installing both new and classic TLS OpenGL libraries.
-> Installing classic TLS 32bit OpenGL libraries.
-> Install NVIDIA's 32-bit compatibility OpenGL libraries? (Answer: Yes)
-> Searching for conflicting X files:
-> done.
-> Searching for conflicting OpenGL files:
-> done.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (310.32):
   executing: '/sbin/ldconfig'...
   executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Shared memory test passed.
-> Running runtime sanity check:
-> done.
-> Runtime sanity check passed.
-> Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver will be used when you restart X?  Any pre-existing X configuration file will be backed up. (Answer: Yes)
-> Your X configuration file has been successfully updated.  Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86_64 (version: 310.32) is now complete.

As shown in the links I provided at the top, the Nvidia X Server Settings and my xorg.conf seem okay. Now for the problem, glxinfo displays this:

glxinfo | grep -i opengl

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string: 2.1 Mesa 8.0.4
OpenGL shading language version string: 1.20
OpenGL extensions:

and Steam's system information displays this: (Error, I do not have enough reputation to post a picture, the picture is near the top of the page of the first link that I posted.)

I believe the problem has to do with the contents of the /etc/ld.so.conf.d. In particular, there are two symbolic links in this folder:

i386-linux-gnu_GL.conf -> /etc/alternatives/i386-linux-gnu_gl_conf and

x86_64-linux-gnu_GL.conf -> /etc/alternatives/x86_64-linux-gnu_gl_conf

cat i386-linux-gnu_GL.conf

/usr/lib/i386-linux-gnu/mesa

and

cat x86_64-linux-gnu_GL.conf

/usr/lib/x86_64-linux-gnu/mesa

I'm almost certain that this is the problem. /usr/lib/x86_64-linux-gnu/mesa is a folder. Here are its contents:

ls -l /usr/lib/x86_64-linux-gnu/mesa | grep -o " l.*"

ld.so.conf
libGL.so -> libGL.so.1
libGL.so.1 -> libGL.so.1.2
libGL.so.1.2

Here are the contents of my /usr/lib:

ls -l libGL* | grep -o lib.*

libGL.la
libGL.so -> libGL.so.1
libGL.so.1 -> libGL.so.310.32
libGL.so.310.32

Here are the contents of my /usr/lib32:

ls -l libGL* | grep -o lib.*

libGL.la
libGL.so -> libGL.so.1
libGL.so.1 -> libGL.so.310.32
libGL.so.310.32

So I assumed I could fix this problem by changing to contents of i386-linux-gnu_GL.conf to just /usr/lib32 and the contents of x86_64-linux-gnu_GL.conf to just /usr/lib.

Unfortunately this causes glxinfo to mess up:

glxinfo

name of display: :0.0
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  137 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x3e00003
  Serial number of failed request:  34
  Current serial number in output stream:  34

and Steam segfaults. I feel like I'm very close to fixing this issue; I'm just not sure what to do or where the best place to ask for help would be.

share|improve this question
    
I've got Mesa issues similar to this, and I have mucked with 32 vs. 64 bit libraries. However, this may lead me close to root cause .. –  david6 Jun 6 '13 at 11:56

1 Answer 1

up vote 0 down vote accepted

I ended up giving up on this. I reinstalled Ubuntu 12.04 and stuck with the pre-compiled binaries. Everything seems to work okay now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.