Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Sublime Text 2 the following way, but what I do not like about it is that I have to run it as sudo to save the user settings files. Any ways around this?

Thanks,

Colin

sudo add-apt-repository ppa:webupd8team/sublime-text-2
sudo apt-get update
sudo apt-get install sublime-text
share|improve this question

1 Answer 1

up vote 2 down vote accepted

The first time you ran sublime, you probably ran it as root. Thus on that first run your user settings where stored as 'root'. To change those permissions to your own do:

sudo chown -R yourusername:yourusername /home/yourusername/.config/sublime-text-2
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.