Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello everyone here are my specs:

  • i7 2600 intel cpu
  • asus p8p67 motherboard
  • 8gb ram kingston
  • ocz agility 240gb ssd
  • 1tb seagate hdd 7200rpm
  • 800w corsair psu
  • evga nvidia gtx680 2gb

I am running on an ASUS 27Inch 2560x1440p monitor.

I have windows 7 running on my seagate hdd. I installed 64 bit 13.04 ubuntu on the ssd. grub allows me to choose between the two and that is working fine. Ubuntu runs very well when I start using it. But then over time the performance starts to deteriorate.

So when I am typing this out now it lags, when I grab a window and move it around it lags. So there seems to be a delay to my actions. If I reboot and log in again it runs fine but then the same problem occurs. If I leave idle for an hour and come back performance suffers?

I installed the latest NVIDIA drivers thinking it may of fixed the problem. To me it seems like some sort of bottlenecking occurs over time? I check the RAM and processes and nothing looks out of the ordinary, any ideas?

Thanks

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

All I had to do was change my NVIDIA driver and now it runs well:

  1. Go to top left icon and search for Software and Updates.
  2. Click on software and updates
  3. Go to the tab named Additional Drivers
  4. I originally had NVIDIA binary Xorg, kernel module and VDPAU library from nvidia-304 (proprietary) OPTION 5.
  5. I changed to NVIDIA binary Xorg, kernel module and VDPAU library from nvidia-310-updates (proprietary, tested)
  6. Rebooted the system
  7. Performs excellent now
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.