Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having an issue upgrading

Here are some of reports

sudo apt-get upgrade

Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-3.2.0-44-generic-pae_3.2.0-44.69_i386.deb


server@philo:/$ sudo apt-get upgrade -f
The following NEW packages will be installed:
  linux-image-3.2.0-44-generic-pae
E: Internal Error, No file name for libssl1.0.0

So I tried this...

server@philo:/mnt/halftb/media/Videos$ sudo dpkg --configure -a

Errors were encountered while processing:
 linux-image-generic-pae

Heres a ton of output...

(Reading database ... 80098 files and directories currently installed.)
Unpacking linux-image-3.2.0-44-generic-pae (from .../linux-image-3.2.0-44-generic-pae_3.2.0-44.69_i386.deb) ...
Done.
dpkg: error processing /var/cache/apt/archives/linux-image-3.2.0-44-generic-pae_3.2.0-44.69_i386.deb (--unpack):
 failed in write on buffer copy for backend dpkg-deb during `./boot/vmlinuz-3.2.0-44-generic-pae': No space left on device
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-44-generic-pae /boot/vmlinuz-3.2.0-44-generic-pae
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-44-generic-pae /boot/vmlinuz-3.2.0-44-generic-pae
Preparing to replace libssl1.0.0 1.0.1-4ubuntu5.8 (using .../libssl1.0.0_1.0.1-4ubuntu5.9_i386.deb) ...
Unpacking replacement libssl1.0.0 ...
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-3.2.0-44-generic-pae_3.2.0-44.69_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
server@philo:/mnt/halftb/media/Videos$ sudo apt-get upgrade -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following NEW packages will be installed:
  linux-image-3.2.0-44-generic-pae
The following packages will be upgraded:
  aptitude bash-completion cifs-utils cups cups-bsd cups-client cups-common cups-ppdc libasound2 libcups2 libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1
  libdrm-intel1 libdrm-nouveau1a libdrm-radeon1 libdrm2 libgnutls26 libtiff4 linux-image-generic-pae linux-libc-dev openssl python-apt python-apt-common rsyslog smbfs
28 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/46.8 MB of archives.
After this operation, 113 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
E: Internal Error, No file name for libssl1.0.0
server@philo:/mnt/halftb/media/Videos$ sudo dpkg --configure -a
Setting up libssl1.0.0 (1.0.1-4ubuntu5.9) ...
dpkg: dependency problems prevent configuration of linux-image-generic-pae:
 linux-image-generic-pae depends on linux-image-3.2.0-43-generic-pae; however:
  Package linux-image-3.2.0-43-generic-pae is not installed.
dpkg: error processing linux-image-generic-pae (--configure):
 dependency problems - leaving unconfigured
Setting up linux-libc-dev (3.2.0-43.68) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 linux-image-generic-pae
server@philo:/mnt/halftb/media/Videos$

edits- additional:

server@philo:~$ sudo apt-get install libssl1.0.0
[sudo] password for server:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libssl1.0.0 is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 linux-image-generic-pae : Depends: linux-image-3.2.0-43-generic-pae but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question
    
Why dont you try this first sudo apt-get install libssl1.0.0? –  thefourtheye May 26 '13 at 13:19
    
I tried a few variants of that, endless loop. I updated the post to reflect. –  wlraider70 May 26 '13 at 13:28

2 Answers 2

Try this:

sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade
share|improve this answer
    
I ran these except not "dist". I don't want to upgrade the distribution. No change. –  wlraider70 May 28 '13 at 13:42
1  
dist-upgrade is not necessarily to upgrade the distribution, though. (It is used when apt-get must remove packages or install new ones in order to update completely.) –  edwin May 29 '13 at 23:35

I had the same issue, it turned out to be a lack of space on /boot:

So, I went to /boot and found a ton of old kernels:

I deleted all except the last three (just to have some fallback :) and ran the apt-get install command again. Worked this time.

Hope this helps, PS

edit - I pasted some output but it didn't format correctly so I removed it.

share|improve this answer
    
How do you know which is a new vs old kernel ? My boot is way close to being full but I'm not sure how to remove the old kernels. –  teewuane Feb 14 at 4:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.