Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f

apt-get install -f gives me

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  kde-l10n-engb kde-l10n-zhcn
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libjack-jackd2-0
Suggested packages:
  jackd2
The following packages will be upgraded:
  libjack-jackd2-0
1 upgraded, 0 newly installed, 0 to remove and 46 not upgraded.
1 not fully installed or removed.
Need to get 0 B/197 kB of archives.
After this operation, 3,072 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 632520 files and directories currently installed.)
Preparing to replace libjack-jackd2-0 1.9.8~dfsg.1-1ubuntu2 (using .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb) ...
Unpacking replacement libjack-jackd2-0 ...
dpkg: error processing /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb (--unpack):
 './usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Details from package manager:

The following packages have unmet dependencies:

libjack-jackd2-0: Depends: libc6 (>= 2.14) but 2.15-0ubuntu10.4 is installed
                  Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed
                  Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is installed
libjack-jackd2-0:i386: Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.4 is installed
                       Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed
                       Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is installed

I changed /usr/share/doc/libjack-jackd2-0/ to /usr/share/doc/libjack-jackd2-0.old/ and apt-get install -f gave me:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  kde-l10n-engb kde-l10n-zhcn
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libjack-jackd2-0
Suggested packages:
  jackd2
The following packages will be upgraded:
  libjack-jackd2-0
1 upgraded, 0 newly installed, 0 to remove and 46 not upgraded.
1 not fully installed or removed.
Need to get 0 B/197 kB of archives.
After this operation, 3,072 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 632520 files and directories currently installed.)
Preparing to replace libjack-jackd2-0 1.9.8~dfsg.1-1ubuntu2 (using .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb) ...
Unpacking replacement libjack-jackd2-0 ...
Setting up libjack-jackd2-0 (1.9.8~dfsg.2-1precise1) ...
Setting up libjack-jackd2-0:i386 (1.9.8~dfsg.2-1precise1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Now all is good. Why?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.