Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a serious problem with my ASUS 1005PX, running Ubuntu 13.04. The keyboard is very slow and working unreliable (e.g. input is 'jjjjj' if 'j' is input) and the touch-pad is dead. In the beginning it worked properly with full touch-pad functionality, but after some time the problems started and now I only can use it with a USB keyboard and USB mouse. This is what I tried:

  1. update BIOS
  2. update kernel to 3.9.3
  3. Instal gpointing-device-settings
  4. edit /etc/modprobe.d/option.conf with options psmouse proto=imps and afterwards run sudo modprobe -r psmouse && sudo modprobe psmouse
  5. edit /etc/X11/gksu gedit xorg.conf and added the text:

Section "InputClass"

Identifier "ETPS/2 Elantech Touchpad"

MatchProduct "ETPS/2 Elantech Touchpad"

MatchDevicePath "/dev/input/event*"

Driver "synaptics"

Option "AreaTopEdge" "50"

EndSection

Then I edited grub by sudo gedit /etc/default/grub and added:

GRUB_CMDLINE_LINUX_DEFAULT="quietly splash acpi_iso=Linux acpi=off "
GRUB_CMDLINE_LINUX="i8042.nomux=1 locale=fr_FR i8042.reset"

I also installed other distro's like ubuntu 12.10; MintKDE 14; DSL; PuppyLinux; Fuduntu; Fedora, Lubuntu 12.10 etc

At this stage, none of the above options solves the problem. Sometimes when a new distro is installed, the touch-pad reacted for short moment. So it is not a hardware problem. Does anyone see a solution?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.