Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I've digged all over google but I can't find any solution to my problem.

Firefox works pretty well. I have this issue only with chromium and only with youtube. I have no problem watching videos at any other site with chromium.

When I try to watch a video a black screen occurs and after a while it gives me the warning "an error occurred". Weirdly, sometimes when I try a couple of refreshing it starts to play but then the issue occurs again.

I tried removing-reinstalling chromium or the flash plugin but it did not do any good.

share|improve this question

marked as duplicate by Florian Diesch, Eric Carvalho, Warren Hill, Jorge Castro, Lucio Dec 5 '13 at 2:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I'm on 13.04 64 bit and it is working fine for me. What version of Flash you using? I'm using 11.2.202.285 successfully. You can check here: helpx.adobe.com/flash-player/kb/find-version-flash-player.html –  brim4brim Jun 4 '13 at 2:07

6 Answers 6

Add &nohtml5=1 to the end of the url to force the page to using flash instead.

As a webdev who loves html5 and really dislikes flash I find it ironic that I'm suggesting this, but until Google fixes whatever is wrong with it's player, this is the only solution I could get to work.

share|improve this answer

The correct answer is here: http://askubuntu.com/a/316722/93826

To solve the issue you have to update the chromium ffmpeg codec to the extra version:

sudo apt-get remove chromium-codecs-ffmpeg

sudo apt-get install chromium-codecs-ffmpeg-extra

share|improve this answer
    
Thanks! This worked for me. In my case, the first command removed chromium-browser and the second command reinstalled it. Youtube videos are now working correctly in Chromium. –  crayzeewulf Nov 29 '13 at 18:03
1  
You can use aptitude instead of apt-get. When you run sudo aptitude remove chromium-codecs-ffmpeg and it will inform you that chromium-browser depends on it, and first its proposition will be to remove chromium-browser. Don't agree as the second option will be to replace chromium-codecs-ffmpeg with chromium-codecs-ffmpeg-extra. And that is what we need. –  voiger Dec 6 '13 at 13:25
1  
Don't remove chromium-codecs-ffmpeg (will uninstall chromium as well). You may just install chromium-codecs-ffmpeg-extra and it will simply replace the 1st one. You can EVEN do this WHILE HAVING CHROMIUM OPENED (how cool is that?) –  Philzen Mar 27 at 18:03

I experienced the same problem with Chromium on Ubuntu 12.04 64bit. Even changing to HTML5 didn't change anything, therefore I don't think it could be a flash issue.

After playing with the settings I discovered, that changing the User Agent to "Google Chrome on Windows" solves the problem. All videos are loading again, maybe Google blocks some old Chrome/Chromium versions, as I haven't installed the latest version for sure.

Anyhow, using the extension "User Agent Switcher" offers a simple solution here.

share|improve this answer
  1. Youtube's HTML5 Player

    An option would be viewing your YouTube videos using HTML5 instead of flash.

    You just have to enter the Youtube HTML5 trial and enable HTML5 viewing, since Chromium offers almost full support of HTML5.

  2. Fixing Adobe Flash

    How do I fix flash issues?

  3. 'Aid' Flash at Chromium

    Type chrome://plugins/ in the address bar you can disable/enable e.g. PPAPI or NPAPI Flash Players.

share|improve this answer

I get the same error message occassionaly, but with HTML5 (at least according to right click). I am not in the HTML5 beta, but was years ago. Both flash en HTML5 work good on other sites.

The solution is to re-enter the youtube HTML5 beta, and immediately leave it again.

share|improve this answer
1  
nope. that did not work for me. it's bit of an odd situation but it seems it's a cookie issue. when i block all youtube cookies everthings fine but can't login. i still can't find a solution. –  cankemik Aug 20 '13 at 23:07
    
That worked for me, I entered HTML 5 Beta, tried to watch a video, restarted the PC, tried to watch a video one more time and leaved HTML 5 Beta, gone to a random video and it is now working. –  Rodrigo Martins Aug 26 '13 at 23:56
1  
Doesn't work for me. The video is still played in the html5 player no matter how what state that toggle is in. The only temporary work around I have at the moment is to switch to the embed link youtube.com/v/videoidgoeshere –  Gerry Nov 18 '13 at 14:23
    
@Gerry The above did not work for me either. But the answer by voiger worked for me. –  crayzeewulf Nov 29 '13 at 18:04

It happens to some people, me too (albeit on 12.04). I went to firefox and the same video plays. It seems that if you disable HTML5 on youtube then the video plays also in chromium.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.