Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I upgraded from 12.10 to 13.04, after struggling a lot, I finally managed to install and run Skype, but no matter what I do, there is no video at all.

I have tried every solution from this site with no results yet.

Does anybody know how to fix this issue?

share|improve this question
1  
If you use other applications that also uses the webcam (ex: Cheese) the webcam works? –  Salem May 25 '13 at 22:28

4 Answers 4

Please make sure that the latest skype version 4.2.0.11-0ubuntu0.12.04.1 is installed on your computer.

sudo apt-get update
sudo apt-get install skype skype-bin
share|improve this answer
    
They're both(well) installed in 13.04 (synaptic checked) ,The camera is working ok (checked with kamoso) the laptop(hp compaq6910p) has WUBI dual booting Ubuntu 13.04/Win7 and when working on windows7's Skype the camera integrates seamlessly,I'm a Linux enthusiastic and really would like to fix this issue ,thanks for your help –  user161811 May 30 '13 at 15:48
    
CORRECTION: I checked the skype version and resulted to be 4.1 whre do i get the 4.2 version? –  user161811 May 30 '13 at 16:25
    
hp@ubuntu:/usr/local/bin$ cat skype ERROR: ld.so: object '/usr/lib/i386-linux-gnu/mesa/libGL.so.1' from LD_PRELOAD cannot be preloaded: ignored. –  user161811 May 30 '13 at 17:07
    
OK I finaly got the 4.2.0.11 skype package and installed it and works o.k. BUT,but....... nobody tells you to pick the dynamic version and install it "manually",otherwise it won't work . –  user161811 May 30 '13 at 20:41
    
Not sure what you mean with dynamic version, but if you had run the commands I suggested above, version 4.2.0.11-0ubuntu0.12.04.1 would have been installed from the Ubuntu archive. Or you could have done it using Synaptic after having clicked the "Reload" button. –  Gunnar Hjalmarsson May 31 '13 at 6:12

Later on, I noticed the skype's notification icon was gone,after doing some research,found this solution: ( How do I get the Skype status icon back? (on panel/tray)) Thanks for your help.

share|improve this answer

Recently I had to re-install Ubuntu 13.04 64amd after a disastrous system crash and found a simpler and better way to get the unpleasant skype and its camera working :first installed synaptic from Ubuntu's software center, then from synaptic installed skype and ia32-libs,later from terminal (not from the launcher) I ran :LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype and PRESTO! webcam working like a charm on skype (only after hours of research ).You can make a script to make it run or you can save the command in a file and pasting it in the terminal every time you need to use skype. Hope this works for anyone just like me with scarce IT knowledge.

share|improve this answer
    
CORRECTION #2 to get synaptic to install skype, first you have to add the deb extras.ubuntu.com/ubuntu raring main and deb-src extras.ubuntu.com/ubuntu raring main packages in the /etc/apt/sources.list file by uncommenting (erasing the # symbol) from the ubuntu's extras packages and how do you get there? type in your terminal sudo gedit /etc/apt/sources.list uncomment the extras packages and sudo apt-get update and you're ready to install skype. don't need to reboot. –  user161811 Dec 3 '13 at 17:09

Go to Skype->Options->Video Devices and check whether you have Enable Skype Video checked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.