Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Dell laptop has an Intel Graphics HD 3000 driving a 1600x900 LCD. However, For some reason, Ubuntu 13.04 and 14.04 won't let me set the resolution above 1024x768. Can anyone offer any advice? Thanks!

$ lshw
<snip>
*-display UNCLAIMED
         description: VGA compatible controller
         product: 2nd Generation Core Processor Family Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: vga_controller cap_list
         configuration: latency=0
         resources: memory:f1400000-f17fffff memory:e0000000-efffffff ioport:5000(size=64)

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       61.0*
   800x600        61.0

# lspci -vvnnk
<snip>
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Dell Device [1028:04c4]
    Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Interrupt: pin A routed to IRQ 16
    Region 0: Memory at f1400000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 5000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
            Address: 00000000  Data: 0000
    Capabilities: [d0] Power Management version 2
            Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
            Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [a4] PCI Advanced Features
            AFCap: TP+ FLR+
            AFCtrl: FLR-
            AFStatus: TP-
<snip>
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 525M] [10de:0df5] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
share|improve this question
    
Notice the "UNCLAIMED" on that display entry -- do you have another display in the output? –  ubfan1 May 25 '13 at 19:23
    
Nope. In fact, the snippet I posted above is actually the complete output of running lshw -C video. –  user161768 May 26 '13 at 22:40
    
I should probably mention this is an Optimus laptop, meaning it has an nvidia GPU as well, but since it can't drive the screen directly I'm not worrying about that for now. –  user161768 May 26 '13 at 22:41
2  
Check out bumblebee for hybrid graphics configuration. Don't use it myself, no need. –  ubfan1 May 27 '13 at 5:20
    
Yeah, bumblebee seems like the Linux way to use the nvidia GPU, but AFAIK it doesn't help with the resolution issue? –  user161768 May 28 '13 at 2:31
show 11 more comments

1 Answer 1

up vote 0 down vote accepted

After discovering recently that 14.04 was affected too, I did some more digging and discovered a few things:

  • Booting with nomodeset is the immediate cause of the problem; I only did this because the laptop in question wouldn't boot otherwise.
  • Booting with noacpi instead solved the video issue, but caused other problems. In particular, only one CPU was detected, when two (or four with HyperThreading) would otherwise be seen.
  • Booting with acpi_osi=Linux acpi_backlight=vendor instead fixed almost all of the problems; the only remaining issue was excessive fan noise.
  • Updating to the latest available BIOS (in combination with the previous bullet) gave me a complete solution.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.