Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my /etc/fstab, I've got this entry:

sshfs#mythbuntu@192.168.0.4:/home/mythbuntu    /Mythbuntu    fuse noauto,users,exec,uid=1000,gid=1000,allow_other,reconnect,transform_symlinks,BatchMode=yes 0 0

Unfortunately, it doesn't work. I don't get any error output anywhere that I can see, the network drive simply doesn't connect.

I've set the owner of /Mythbuntu to be dave:dave, and the permissions to 755. Not sure if that's how it should be, but that's what I've tried for now.

If I set the target directory to be in my home directory, it works fine. So, this entry in /etc/fstab works fine:

sshfs#mythbuntu@192.168.0.4:/home/mythbuntu    /home/dave/Mythbuntu    fuse noauto,users,exec,uid=1000,gid=1000,allow_other,reconnect,transform_symlinks,BatchMode=yes 0 0

For various reasons, I'd really like to be able to create the mount point at /Mythbuntu and not /home/dave/Mythbuntu.

Where am I going wrong, and how do I get the mount to work?

share|improve this question
1  
I would approach this by trying to get it to print an error message somehow. What happens if you attempt the same mount at the command line rather than via fstab? –  Paul May 25 '13 at 16:42
    
@Paul: When I type mount -a at the command line, I get no output. Is there another command I should try? –  Dave M G May 25 '13 at 21:45
    
I was thinking sshfs mythbuntu@192.168.0.4:/home/mythbuntu /Mythbuntu -o noauto,users,exec,uid=1000,gid=1000,allow_other,reconnect,transform_symlinks,Bat‌​chMode=yes, just to see whether it's something to do with the server / mount point or something to do with fstab. –  Paul May 25 '13 at 21:56
    
@Paul, thanks for following up. If I use that command, I get an error for each option following the -o: fuse: unknown option 'noauto', fuse: unknown option 'users'... and so on. Given that these options work when I mount to my home directory, I'm guessing the command line syntax would differ from the fstab entry syntax. –  Dave M G May 25 '13 at 22:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.