Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set the the time using, e.g.

sudo date --set="24 MAY 2013 18:00:00"
sudo hwclock --systohc --utc

This worked, but upon reboot the time was back to the old value. What am I doing wrong? I thought hwclock would make it permanent.

I notice in the gui time/date my timezone is still set to a different timezone and Network Time is set to on. So I wonder if it's somehow autosyncing, or if I need also change the time zone at terminal?

share|improve this question
    
Where are you? Are you set your Time Zone correctly? Double check it ;) –  S.M.Mousavi May 25 '13 at 11:39
    
The time-zone is currently set to Europe/Paris, I want it set to London time. As I mention in the OP, I haven't tried setting the time-zone at all from the terminal, I was just trying to set to time manually with the date command (which worked but didn't stay after reboot). Are you suggesting that I also need to somehow adjust the time-zone from terminal too? –  fpghost May 25 '13 at 11:46
    
Does time-zone take precedence over the time set via date? –  fpghost May 25 '13 at 11:48
1  
@fpghost... Certainly! –  S.M.Mousavi May 25 '13 at 11:49
    
@fpghost... Ubuntu will update Date/Time using your location info. Therefore Date/Time will be updated on booting operation or some period of time according to your location(TimeZone) using internet services. –  S.M.Mousavi May 25 '13 at 11:53

1 Answer 1

up vote 6 down vote accepted

To choose your system time zone from a terminal:

sudo dpkg-reconfigure tzdata
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.