Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My problem already listed in the forum but unfortunately it is closed and no satisfying answer available in that post. So, I am opening a new thread.

I am using ubuntu 13.04. I changed my password using passwd command for the user. Ex: Suppose 'XYZ' is the username I am using to login. I used this command to change the password of that user:

sudo passwd XYZ

It prompted me to enter my current password and later new password twice. everything is fine. But after changing user password successfully, I log-out and tried to log-in. I failed.

After entering my password and pressing enter, it simply goes blank for 1 or 2 seconds and re-appears the log-in screen. I am unable to enter. At the time of installation I used "encryption of home folder" option. So, I am unable to access my data from windows. (As you know that We can have read access of linux partition using some softwares).

Please help and thanks in advance.

share|improve this question
up vote 0 down vote accepted

Try this.

Boot into recovery mode, and change the password. Boot your computer, and quickly press the Shift key or Escape, which will bring up a boot menu.

When you get the grub menu, select option with recovery mode

enter image description here

This will take you to recovery menu. In recovery menu select option drop to root shell.

enter image description here

To change the password type the command below at the prompt:

   passwd <user_name>

You will be asked you to enter your new password and retype password. Type your new password. Once done resume normal boot, and try to login.

share|improve this answer
Thanks for quick reply. I tried this but I got this error message. Passwd: Authentication token manipulation error Passwd: password unchanged. – Srikanth May 26 '13 at 9:02
Try this before the command to change the password mount -rw -o remount / – Mitch May 26 '13 at 9:11
Hi thank you for the reply. That worked for me. Problem solved. – Srikanth May 26 '13 at 10:23
If this answered your question, you may mark this answer as accepted. – Mitch May 26 '13 at 10:24
Accepted the answer. Thank you. – Srikanth May 26 '13 at 15:27

When you are at the login screen in Ubuntu, go in tty1 with Ctrl+Alt+F1, login with your user name and password, and run this command:

sudo chown -R $USER:$USER /home/$USER/

Now reboot (sudo reboot) and try to login as usually.

share|improve this answer
Thanks for the quick reply. I tried it but didn't worked for me. – Srikanth May 26 '13 at 9:02
Thanks for the quick reply. I tried it but didn't worked for me. it didn't give any error message either. After rebooting, the problem remains. It accepts my password, and goes 1 or 2 seconds blank and back to the log-in screen without showing any errors (like password incorrect). – Srikanth May 26 '13 at 9:07
@Srikanth Did yu changed $USER with the username that have this problem - aka 'XYZ'? – Radu Rădeanu May 26 '13 at 9:26
Hi, Thank you for the reply. yeah, I replaced it with my username. Anyway my problem solved now. I changed back to my previous password. Using the instructions given by Mr/Ms Mitch. – Srikanth May 26 '13 at 10:27
@Srikanth Ok, if his answer was usefull, you must to accept it. – Radu Rădeanu May 26 '13 at 10:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.