Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to make an Ubuntu app in Vala. I do have knowledge of C++ so the syntax isn't that difficult to learn. But I'm doing something wrong with the needed packages: I need libsoup to communicate with an online API, and a json package. I tried to compile with this command: valac --thread --pkg libsoup-2.4 --pkg json-glib-1.0 json-example.vala

I get following error: /home/brendt/programs/vala/json-example.vala.c:9:26: fatal error: libsoup/soup.h: No such file or directory compilation terminated. error: cc exited with status 256 Compilation failed: 1 error(s), 0 warning(s)

So this makes me think I haven't installed that libsoup package in the correct place. I tried apt-get install, but than Ubuntu says the package is already installed. Than I tried cloning from git, but I don't really find a way to compile the source I get than..

anyone has some suggestions? I probably have to add a correct path somewhere, but I don't know where. regards, brendt

share|improve this question
up vote 2 down vote accepted

You need to install the development package for libsoup:

sudo apt-get instal libsoup2.4-dev
share|improve this answer
Thanks, that's the solution indeed – Brent Roose May 27 '13 at 19:00

So this is a problem that you are experiencing while compiling your app or when using it ?

Show the complete command that you give to compile this application and say if you have this .so library in your LD configuration.

share|improve this answer
valac --thread --pkg libsoup-2.4 --pkg json-glib-1.0 json-example.vala is how I compile. I never heard of LD configuration or .so library, so could you explain that? that's probably the issue – Brent Roose May 25 '13 at 10:13
Make this a comment rather than an answer. – Devyn Collier Johnson Dec 14 '13 at 2:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.