Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Skype fails to connect after update to 4.2.0.11

I am not sure if I'm looking at a network problem or a bug here. Since the update to 4.2.0.11 my Skype can't connect any more. My room-mate has the same problem. We're both on Ubuntu Raring Ringtail 13.04 on an EliteBook 9470m in my case. Does anyone have the same problem, or do you know of a bug-report?

(Update: Turns out it's neither a bug nor a network problem. Tor exit-nodes are blocked by Microsoft. See my answer below!)

Both purge-reinstall (including the removal of ~/.Skype) and using the .deb from skype.com (version 4.2.0.11_1) instead of the repositories did not help. Running Skype from the command line did not give additional messages.

I don't know how to decode the log files in ~/.Skype/Logs but the usual logs in /var/log/ show no anomalies. Changing the port Skype uses to one that is forwarded to my machine by the router, did not work either. Nor did running Skype as root.

The fact that I can get it running on the same machine, when I use tethered connection of my mobile points towards a network problem, but then again other machines in our household have no problem at all and I didn't change any network configurations for half a year.

Changed port

share|improve this question
    
In Skype's community forum the issue is currently being discussed and has attracted the attention of one of the staff members. We will see how this is going. At least I don't seem to be alone. –  con-f-use May 26 '13 at 19:20
    
There is no 64bit version of Skype 4.2. The 32bit version is considered to be "multiarch" and forced. Also I don't see where nvidia related fixes for the GUI should help my login problems (especially as I don't have an nvidia card). The GUI works just fine. Also libqt4-network is automatically reconfigures after a purge install. I tried it nonetheless to no avail. –  con-f-use May 27 '13 at 13:45
    
    
I did. You can read that in my question above. This is the official file from skype.com. The name says right there that it is an i386-package. Look I appreciate your effort but these are all obvious things and you're just guessing. –  con-f-use May 27 '13 at 13:53
    
There is already a bug open for it on Launchpad, please add yourself as affected. bugs.launchpad.net/ubuntu/+source/skype/+bug/1184128 –  user162687 May 29 '13 at 7:13
show 1 more comment

3 Answers

Update: Turns out this answer is wrong. The problem here was Skype blocking IPs operating a Tor exit node. See answer below.

However the answer might be helpful in solving other problems.


Here is what I did.

All this was done using terminal. Just press Ctrl+Alt+T on your keyboard to open Terminal.

I removed the old Skype, using sudo apt-get autoremove --purge skype, and removed ~/.Skype folder.

I then installed Skype 4.2.0.11 this way.

wget -O skype-NoobsLab.deb http://download.skype.com/linux/skype-ubuntu-lucid_4.2.0.11-1_i386.deb
sudo dpkg -i skype-NoobsLab.deb
sudo apt-get -f install;rm skype-NoobsLab.deb

After the installation was done, I typed Skype in Dash, clicked on it, and when it opened, I put in my user name and password, and was able to log in. See below.

enter image description here enter image description here enter image description here enter image description here

Note: I used the 32bit Skype, and there were no problems.

This method will automatically detect OS architecture and install latest skype:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install skype && sudo apt-get -f install

Note: I had to install libqt4-webkit, and for that I used Synaptic.

Source: Noobslab

share|improve this answer
    
Very nice and complete answer but I found those instructions on the web already and tried them. I cannot connect even with this version of Skype (and why should I as they use the same binary?). I really appreciate your effort but it seems to be a substantial thing of either my ISP or Skype itself. By the way dpkg gives me the message "Errors were encountered" but installs anyway. Do you know what the problem here is? –  con-f-use May 28 '13 at 12:44
    
Well, are you on 32bit or 64bit Ubuntu? –  Mitch May 28 '13 at 12:45
    
The 64Bit version uses the same binaries as far as I know. The difference is just a force-architecture flag in the package. The second method is just the official package which I had installed previously. –  con-f-use May 28 '13 at 12:49
    
Just an idea. I will try the same on 13.04 64bit, and let you know. –  Mitch May 28 '13 at 12:52
    
Skype is running on my machine just not connection. So it can't be an architecture issue between 64 and 32Bit, else it wouldn't be running at all. –  con-f-use May 28 '13 at 13:01
show 4 more comments
up vote 3 down vote accepted

The recent consensus is that Skype doesn't work well with tor and similar programs. That's what's causing the problems. Skype has automatically blocked a few massive amount of IPs running tor exit nodes. If you are experiencing the problem so far there are only two practical ways around it:

  1. Disable tor (both node and client usage!). After a day or two Skype should start working again. Should the problem persist enable logging:

    mkdir ~/.Skype/Logs
    cd ~/.Skype/
    mv shared.xml old_shared.xml
    sed 's/<Lib>/<Lib>\n    <LogLevel>3</LogLevel>/g' old_shared.xml > shared.xml
    

    Then restart Skype, wait for the error to occur. After it post your logs in ~/.Skype/Logs in the appropriate thread of the Skype forum. They will help you! They will not react.

  2. Configure a proxy for use with Skype:

    1. Click the Skype-Icon and select Options

    2. Under Advanced, put your proxies details for Host, Port and optionally User and Password in the appropriate fields. If you don't know a good proxy already, you need to find a trustworthy list via google. I found hidemyass to be useful. Security is more important than speed!enter image description here

    3. Make sure ports are forwarded to your PC (for your proxy and incoming) connections).

  3. Use a VPN connection (e.g. company or university network)

Update:

Skype support does not react to inquiries into this problem anymore. I find that very disturbing. There are multiple closed threads - all labeled offtopic. Either tor is unwanted because it gets in the way of data mining or tor users are indiscriminately blocked because of the spam emanating out of the network into Skype. Both explanations are ultimately evil.

share|improve this answer
    
So you were using tor .......thats funny you didn't tell us that you are using tor... +1 for updating –  Qasim Jun 12 '13 at 14:23
    
I didn't think it matters. I ran the exit node for 2 years without a problem. Also I had disabled it for a while. Even the Microsoft/Skype guys took forever to find the problem. –  con-f-use Mar 23 at 11:44
add comment

Did you try to fix the packages ?

sudo apt-get update && sudo apt-get install -f && sudo apt-get update && sudo apt-get upgrade -y
share|improve this answer
    
Yes, to no avail. There were no broken packages. Thanks for your answer though. –  con-f-use May 25 '13 at 9:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.