Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am authenticating a network using WPA2, but not working (authenticates then off)

OS: Ubuntu 13.04 Wireless network card : Intel Corporation Ultimate N WiFi Link 5300

$dmesg:
[ 1248.966666] wlan0: authenticate with 00:20:a6:bb:ff:e1
[ 1248.969571] wlan0: send auth to 00:20:a6:bb:ff:e1 (try 1/3)
[ 1248.986155] wlan0: authenticated
[ 1248.986417]iwlwifi 0000:02:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[ 1248.986425] iwlwifi 0000:02:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[ 1248.988049] wlan0: associate with 00:20:a6:bb:ff:e1 (try 1/3)
[ 1248.990384] wlan0: RX AssocResp from 00:20:a6:bb:ff:e1 (capab=0x31 status=0 aid=1)
[ 1248.995162] wlan0: associated
[ 1251.042674] wlan0: disassociating from 00:20:a6:bb:ff:e1 by local choice (reason=3)
[ 1251.201126] cfg80211: Calling CRDA to update world regulatory domain
[ 1251.201392] wlan0: deauthenticating from 00:20:a6:bb:ff:e1 by local choice (reason=3)
[ 1251.209426] cfg80211: World regulatory domain updated:
[ 1251.209433] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1251.209438] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1251.209442] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1251.209446] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1251.209450] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1251.209453] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
root@jafa:~# 

$Lshw
*-network
                description: Wireless interface
                product: Ultimate N WiFi Link 5300
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:02:00.0
                logical name: wlan0
                version: 00
                serial: 00:21:6a:93:b4:48
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=iwlwifi driverversion=3.8.0-21-generic firmware=8.83.5.1 build 33692 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
                resources: irq:47 memory:f4200000-f4201fff

$iwlist wlan0 genie
wlan0     no generic IE (Operation not supported).

$sudo iwlist wlan0 encryption
[sudo] password for josimar:
wlan0     2 key sizes : 40, 104bits
          4 keys available :
        [1]: off
        [2]: off
        [3]: off
        [4]: off
          Current Transmit Key: [1]

$lsusb
02:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300
    Subsystem: Intel Corporation Device 1101
    Flags: bus master, fast devsel, latency 0, IRQ 47
    Memory at f4200000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: [c8] Power Management version 3
    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [e0] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Device Serial Number 00-21-6a-ff-ff-93-b4-48
    Kernel driver in use: iwlwifi


lsmod
Module                  Size  Used by
pci_stub               12550  1
vboxpci                22896  0
vboxnetadp             25636  0
vboxnetflt             27261  0
vboxdrv               285137  3 vboxnetadp,vboxnetflt,vboxpci
parport_pc             27504  0
ppdev                  12817  0
bnep                   17669  2
rfcomm                 37420  0
bluetooth             202069  10 bnep,rfcomm
snd_hda_codec_realtek    63791  1
binfmt_misc            17260  1
uvcvideo               71279  0
videobuf2_vmalloc      12920  1 uvcvideo
videobuf2_memops       13042  1 videobuf2_vmalloc
videobuf2_core         39161  1 uvcvideo
videodev               95806  2 uvcvideo,videobuf2_core
joydev                 17097  0
arc4                   12543  2
iwldvm                220185  0
mac80211              526519  1 iwldvm
coretemp               13131  0
snd_hda_intel          38307  5
snd_hda_codec         117580  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13272  1 snd_hda_codec
snd_pcm                80890  3 snd_hda_codec,snd_hda_intel
snd_page_alloc         14230  2 snd_pcm,snd_hda_intel
snd_seq_midi           13132  0
snd_seq_midi_event     14475  1 snd_seq_midi
snd_rawmidi            25114  1 snd_seq_midi
iwlwifi               155077  1 iwldvm
i915                  535507  4
drm_kms_helper         47545  1 i915
snd_seq                51280  2 snd_seq_midi_event,snd_seq_midi
microcode              18286  0
cfg80211              436177  3 iwlwifi,mac80211,iwldvm
drm                   228750  5 i915,drm_kms_helper
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              24411  2 snd_pcm,snd_seq
psmouse                81038  0
serio_raw              13031  0
lpc_ich                16925  0
i2c_algo_bit           13197  1 i915
wmi                    18590  0
snd                    56485  18 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device
jmb38x_ms              17177  0
memstick               15842  1 jmb38x_ms
soundcore              12600  1 snd
video                  18894  1 i915
mac_hid                13037  0
lp                     13299  0
parport                40753  3 lp,ppdev,parport_pc
hid_generic            12484  0
usbhid                 41805  0
hid                    82666  2 hid_generic,usbhid
firewire_ohci          35292  0
sdhci_pci              18158  0
ahci                   25507  4
sdhci                  31824  1 sdhci_pci
firewire_core          61718  1 firewire_ohci
libahci                26108  1 ahci
r8169                  61531  0
crc_itu_t        
share|improve this question
add comment

1 Answer 1

I've been having the same problem since about a week after upgrading to 13.04.

Found related bug here: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1104476

Please tell launchpad that the bug affects you! :)

Workaround found here: How to connect to wpa2 enterprise mschapv2?

Remove

system-ca-cert=true

from the configuration file found in /etc/NetworkManager/system-connections/

Wireless works again after removing this!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.