Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have NPAPI flash player disabled and everything runs fine until I use VLC player.

So, the thing is: I open Chrome, then VLC, watch the movie there (not necessary till the end), stop it and then open flash audio player. The audio is faster than normal. This effect persists until I logout or restart pulseaudio (pulseaudio -k).

So, this is definitely a bug. Is there a workaround?

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

I had the same problem in Chrome as well, just noticed it recently, was fine before. I found that disabling the VLC Multimedia Plugin in Chrome (chrome://plugins) solved the issue.

share|improve this answer
add comment

The only workaround I found with Google Chrome is to disable PepperFlash in chrome://plugins and enable Shockwave Flash. That took care of the sound issue. So if you can do without PepperFlash, that might fix it for you.

For what it's worth, I'm using the adobe-flashplugin from the partner repository, not the flashplugin-installer. I understand (from a page on askubuntu) that adobe-flashplugin is better for 64-bit systems.

share|improve this answer
    
Well, Shockwave flash is crappy on multi-monitor configurations, so I can't use it. But thanks for the answer! –  GamePad64 May 25 '13 at 10:41
add comment

The issue is with PepperFlash not checking or caring what Pulseaudio's default sample rate is. One can change Pulseaudio's sample rate to 48000, then restart Pulseaudio/Chrome.

Un-comment default-sample-rate and change it to 48000:

$ sudo nano /etc/pulse/daemon.conf

;default-sample-rate = 44100

default-sample-rate = 48000

Read more about the Chromium bug

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.