Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After (as I suppose) updating my Ubuntu 12.04 is refuses to change keyboard layout and only allows me to type in english. It even doesn't show language bar at the top. What is the way to solve that problem?

/here are screens of 'Keyboard layout' and 'Language support' from my 'System settings'/

enter image description here

enter image description here

share|improve this question
    
Just noticed that in log-in screen input language switcher works properly –  pink.fascist May 25 '13 at 7:52
add comment

3 Answers 3

In the "Language Support" dialog, drag your prefered language above "English". "English" must be last in the list.

share|improve this answer
add comment

Try deleting the English entry in Keyboard Layout and in Language Support drag the options to put your preferred languages in order, so that Russian will be first and English last in the list, then click the button Apply System-Wide.

share|improve this answer
    
I removed English, but there's still no language indicator at the top, and I can type only in english –  pink.fascist May 25 '13 at 7:16
    
I know this is somewhat dumb, but have you tried to update your system(sudo apt-get upgrade)? And does the command sudo apt-get update returns any errors? –  Rodrigo Martins May 26 '13 at 1:31
    
Yeah, I tried, no errors :( –  pink.fascist May 26 '13 at 6:05
add comment

In the keyboard Layout window press the Options botton. In the displayed options around the middle there is a section "Key(s) to change layout" Take a look at it and change it to your liking.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.