Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am performing clamtk - virusscan as usual (at a friends computer with 12.04 - updated today):

sudo clamtk

Then normal scanning of all files. When reaching certain file, it crashes with logout to gdm-login-window.

Should I use clamtk-frontend only as normal user?

As a normal user the same happens again - after scanning first 99 files of whole file-system.

When one time click on gdm-user then it crashes again, then back to gdm.

Again click on gdm-user and login works.


from Terminal with command clamtk it is running a bit longer - but still crashes and logout at once into gdm ???

I found for to report crash:

apport-retrace

which is not installed by default (contrary to earlier Ubuntu-Versions).

made then:

apt-get install --reinstall clamtk

and

apt-get install --reinstall gdm

now I make reboot (am back soon ... )

no change ... still crashes. then I tried

apt-get install --reinstall xserver-xorg

(suiting packages to installation)

but it is refused because of too many collisions ??? (on different machines was these packages to reinstall no problem ?)

share|improve this question

3 Answers 3

related hint on the right side gave me this:

2.6.35-28 kernel update breaks Xorg

It seems that linux-headers-generic were missing when kernel updated today, but they are needed when nvidia-files are substituted too by newer files ... ... this causes the crash ? - right ?

share|improve this answer
    
If you suspect linux-headers-generic were missing, try sud apt-get update && sudo apt-get dist-upgrade again. –  carnendil May 24 '13 at 17:56

Yes, you should typically run clamtk as a regular user. Also, if the problem is not fixed by the linux-headers-generic answer above, please run clamtk from the commandline (just type

clamtk

and post back any errors or messages upon the crash.

share|improve this answer

Sorry it is solved by something completely different (at 12.04 LTS 2 of my friend) :

In "system settings" then "brightness and lock" there time should be set to 30 minutes and lock should stay "switched off".

There the default-settings are not correct and causes the crash into gdm ?

But clamtk is still crashing ?

Now it seems that 13.04 has the same at some installations of other Ubuntu-Users.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.