Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm setting up a mining rig using 3-7950's, and have ran into a little bit of a road block. I've seen a few guides using xubuntu 12.10, but none with xubuntu 13.04.

darth_bunny's guide

cryptobadger's guide

gentoo (bitcoin)

I've tried the first 2 ways on fresh images, but for some reason X never starts...

aticonfig --adapter=0 --od-getclocks
ERROR - X needs to be running to perform AMD Overdrive(TM) commands

Following the darth_bunny's guide way I built to 13.04 instead of 12.10

./amd-driver-installer-catalyst-13.3-beta3-linux-x86.x86_64.run --buildpkg Ubuntu/raring

On a side note, whenever I plug the ATI cards in, video (connected to onboard), does not output. I'm guessing this is because the ATI cards are primary? It didn't bother me as I ssh in anyway.

I also have some missing lib's when trying to run cgminer, but that is something to worry about later.

Has anyone solved this on 13.04, or should I just downgrade to 12.10?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

So for the rest of you I hope this is useful. I disabled the onboard video, and plugged into card.

Re-ran

sudo aticonfig --adapter=all --initial -f

rebooted, all devices were enabled.

By default cgminer looks for libudev.so.0, and will not run until it's happy so I set a link up to the newest version.

cd /lib/x86_64-linux-gnu
sudo ln -s libudev.so.1.2.2 libudev.so.0

xubuntu 13.04 = happy

share|improve this answer
    
This doesn't work in 13.10 any ideas? –  Goddard Nov 27 '13 at 17:22
    
Without trying it on 13.10 myself I wouldn't know. I recently switched to BAMT (Debian) 1.1 What exact error are you getting. –  atrueresistance Nov 28 '13 at 18:58

It appears over-zealous moderators are not allowing me to post a very pertinent answer to this question which also appears elsewhere (the questions are related). So I'll just link to the related question below. Answers are pertinent for Ubuntu 13.10.

Mining with Ubuntu and sgminer

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.