Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to deploy a local charm I get the following error:

error: cannot get latest charm revision: no charms found matching "local:precise/devenv"
share|improve this question
add comment

2 Answers

It's worth double checking that your metadata.yaml file is correct. First check that it's valid yaml and then double check that it follows the same format as some of the existing charms in the charmstore

share|improve this answer
    
Does charm proof work for verifying metadata yaml? –  Marco Ceppi May 24 '13 at 13:27
add comment

I had the same problem today. Problem I had was that I accidentally copy/pasted white space in my config.yaml file. Make sure your config.yaml is uniform and has the same structure from beginning to end.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.