Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed these AMD drivers for my HD 5770: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx

When I launched Steam it threw me an error that something was wrong with OpenGL, told me that performance may suffer and let me proceed. After that I attempted to download CSS, but because it was slow and didn't exit I force killed the "steam" process. After I reboot the PC I get the login screen, which I can log in from but when logged-in I get no Unity, no Dashboard etc etc. Only my desktop background, the mouse pointer. I suspect the problem may be with the drivers displayed above, how could I remove those drivers?

EDIT: When I boot to guest mode (I can't bring up the terminal on normal account because of different layout) and launch CCSM it tells me when I enable the Unity plugin that it needs to also enable OpenGL(asks me that twice) and some other plugins.

EDIT 2: Whenever I try sudo apt-get purge fglrx I get told that the package does not exist.

Unity does not start after installing the fglrx drivers

I've tried the answers here but none of these help.

share|improve this question
    
If you're being told the package doesn't exist, it means you've already removed it and can ignore that bit. The second step of my answer should, then, bring back Unity for you (fingers crossed!) –  Jez W May 24 '13 at 11:49
    
With the second command I catch an error about not being able to spawn a command line. ("dbus launch autolaunch--[long string] binary-syntax --close-stdr": Child process exited with code 1) –  shortnamed May 24 '13 at 11:57
add comment

1 Answer

up vote 0 down vote accepted

I had a very similar problem (unrelated to steam, but the fglrx drivers after upgrading to 13.04)

The solution, for me, was as follows:

Login, and press ctrl-alt-T to bring up a terminal.

sudo apt-get purge fglrx

Then reboot. Login again after the restart, and put the following into a terminal window:

gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

It took a while to actually run for me (maybe about 5 or 10 minutes, can't remember for sure) but eventually unity came back.

Hope this is of some help.

EDIT: Just noticed your bit about problems with the terminal. If the terminal window doesn't come up for whatever reason, try ctrl-alt-F2 to open console mode - log into your account to run the command there. Hopefully that'll work as a fallback.

share|improve this answer
    
When I attempted to run sudo apt-get purge fglrx I get told that the package does not exist. When I attempt to run the second command(in ctrl+alt+f1) I catch an error about not being able to spawn a command line. –  shortnamed May 24 '13 at 11:49
    
Strange. I didn't get any such error when I did it. Have you also tried dconf reset -f /org/compiz/ ? –  Jez W May 24 '13 at 12:04
    
I edited some keyboard settings and managed to get the terminal up on my admin account, from which I ran the second command which fixed it. Thank you so much! –  shortnamed May 24 '13 at 12:15
    
Brilliant, glad to hear that it worked! Out of interest, was it 13.04 that had the problem for you too? –  Jez W May 24 '13 at 12:24
    
I had used 13.04 for some days, not sure what broke them for me. –  shortnamed May 24 '13 at 12:33
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.