Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I write an email in Mozilla, the spellcheck shows 21 entries for Spanish (Cuba, Ecuador, Spain ...) 3 entries for English (Australia, UK, US), 4 entries for French (modern, classic, reform, classic/reform). Is there a way to make it show up only the ones I am interested in (for example, Spanish (Spain), English(US), French(modern))? It is very uncomfortable to search for the language I need among them all. I found this bug report: https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/651586 but seems it is not solved. Any clues? Thanks in advance

share|improve this question

3 Answers 3

up vote 5 down vote accepted

I finally found the solution: close Mozilla Thunderbird then

  1. for the English and Spanish dictionaries: go to /usr/share/hunspell/ and remove everything but
    • en_US.aff
    • en_US.dic
    • es.dic
    • es_ES.aff
    • es_ES.dic
  2. for the French dictionary: go to ~/.thunderbird/*.default/extensions/[email protected]/dictionaries/ and remove everything but
    • fr-modern.aff
    • fr-modern.dic

Obviously, instead of actually removing those entries, you can create a folder named "hide" and put the entries you don't want in it.

Now when you write a email and right-click, it only shows up English (US), Spanish (Spain), French (modern)

share|improve this answer

I am not sure since I have not that many languages installed bud did you check the tools -> add-ons -> Languages section. can you disable the required languages?

share|improve this answer
    
Yes, I did. In the section Languages of tools, there are only three entries: English(GB), Español(AR), Español(España). The French dictionary is showing up in the Extension section of tools, but again as a single entry. Obviously if I disable one of those, I will disable all the dictionaries in that language. –  gg-79 May 24 '13 at 8:45

1) Select Languages

If you go to System Settings, the click on Language Support.

If you then click on the Install/Remove languages... button. This allows you to deselect/select the languages you want on your system.

Once the correct languages are selected, click on Apply Changes.

To sort them to your preferred defaults, click and drag the default item on the list of installed languages to the top of the list.

To make these settings apply System wide, click on the System Wide button


2). Regional Formats

The Regional Formats tab allows you to choose the way dates and numbers are displayed on your system.

share|improve this answer
1  
Already tried that: 1) When I click Install/Remove languages there are only English and Spanish checked. In the language tab of Language Support I can see all the languages showing up in the spellcheck, but they are all grayed out a part of English and English(United States). 2) The Regional Formats tab has nothing to do with this problem I think. –  gg-79 May 24 '13 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.