Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed ubuntu 13.04 in family machine, and I faced strange problem

even though my sudo password is correct, I cannot start any GUI application (i.e. bleachBit (as root)) as a root, the system will not except my password. I can use terminal to open GUI application, however, this machine is for my family and I do not want them to miss up the system by playing with terminal,

I searched for a while in the internet trying to find solution but I could not,

to cover the basics below is my /etc/group and /etc/soduers

I am a member of sudo group and adm group

I added my name as member of root group but i did not work, still the system will not except my password in any GUI application

I will inter my password three times then the system will clam I used wrong password

/etc/soduers

    #
    # This file MUST be edited with the 'visudo' command as root.
    #
    # Please consider adding local content in /etc/sudoers.d/ instead of
    # directly modifying this file.
    #
    # See the man page for details on how to write a sudoers file.
    #
    Defaults        env_reset
    Defaults        mail_badpass
    Defaults        secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

    # Host alias specification

    # User alias specification

    # Cmnd alias specification

    # User privilege specification
    root    ALL=(ALL:ALL) ALL

    # Members of the admin group may gain root privileges

%admin ALL=(ALL) ALL

# Allow members of group sudo to execute any command
%sudo   ALL=(ALL:ALL) ALL

# See sudoers(5) for more information on "#include" directives:

#includedir /etc/sudoers.d

/etc/group

root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:ubuntu
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:ubuntu
fax:x:21:
voice:x:22:
cdrom:x:24:ubuntu
floppy:x:25:ubuntu
tape:x:26:
sudo:x:27:ubuntu
audio:x:29:pulse
dip:x:30:ubuntu
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:
sasl:x:45:
plugdev:x:46:ubuntu
staff:x:50:
games:x:60:
users:x:100:
nogroup:x:65534:
libuuid:x:101:
crontab:x:102:
syslog:x:103:
fuse:x:104:
messagebus:x:105:
avahi-autoipd:x:106:
ssl-cert:x:107:
lpadmin:x:108:ubuntu
netdev:x:109:
whoopsie:x:110:
mlocate:x:111:
ssh:x:112:
utempter:x:113:
rtkit:x:114:
bluetooth:x:115:
lightdm:x:116:
nopasswdlogin:x:117:
avahi:x:118:
scanner:x:119:
colord:x:120:
pulse:x:121:
pulse-access:x:122:
saned:x:123:
ubuntu:x:1000:
sambashare:x:124:ubuntu
vboxusers:x:125:ubuntu

I hope some one can help

thanks

share|improve this question

1 Answer 1

I found a an official solution that I like to share with all ubuntuors

when I reviewed application that required root access I noticed they use the following command

su-to-root -X -c

not sudo or gksudo which is strange ( at least for me)

since Ubuntu by default disable root account I enable to enable it using the following command

sudo passwd root

I enabled the root account, then clicked on GUI application ( bleachbit (as root)) to see if it is going to accept the root password and it did :)

finally

I test fresh ubuntu 13.04 installation in a virtual machine and it did not have the same problem as my original machine (my family machine)

it seems there is bug in my system not in the original ubuntu os

I hope this could help some one, and I appreciate any comments or notes

share|improve this answer
1  
Can I advise you to click the contact us link at the bottom of this page to ask for your two accounts to be merged? By doing this, you'll be able to accept your own answer. –  fossfreedom May 24 '13 at 17:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.