Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run unattended-upgrade with Allowed-Origins set to security and nothing listed in the blacklist. However when I run unattended-upgrade -d, the log lists a blacklist with all my security updates listed. No packages are updated. What could I be doing wrong? Any help would be appreciated.

share|improve this question
I too suffer from this, unfortunate that nobody has answered. 11 out of my 12 servers fail to do updates. – Daniel Huckstep Dec 27 '13 at 4:24
On my Debian system it was because I was still running squeeze (oldstable) instead of wheezy (stable). Therefore, in the /etc/apt/apt.conf.d/50unattended-ugprades I had to change "${distro_id} stable"; to "${distro_id} oldstable";. But I don't know if this can be applied to Ubuntu. – robert Jan 20 '14 at 18:57
Could you add the configuration file of unattended-upgrades? The default is to do nothing. – Braiam Aug 14 '15 at 13:45
unlikely, he has never been seen again since Nov 13 :-) – guntbert Aug 15 '15 at 19:32

OK what I did and it worked.

  1. when the update appears unclick the Ubuntu base upgrade leave every thing else.
  2. it should give you an error like its a dependent upgrade.
  3. then go to the Ubuntu softwarecenter "this is what fixes it" it shouldn’t work it asked if you want it fixed say yes. 4.then rerun the Ubuntu upgrade this time clicking the Ubuntu base on so its clicked.
  4. and you are done takes about 5 mins.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.