Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to Ubuntu 13.04 I have a problem with the fonts in some apps. When I use gvim or fontconfig, all the fonts available look the same. It doesn't matter which one I chose, it always defaults to the same ugly default. When I try to choose a different font in gnome-terminal preferences, it crashes.

Font usage in libreoffice is fine.

I have removed all the files in /var/cache/fontconfig. I issued fc-cache -r. I removed ~/.fonts directory. I uninstalled and reinstalled all the ttf-* packages and some more.

What else can I try ?

share|improve this question

1 Answer 1

Removing the following packages fixed this for me:

  • libpango1.0-common (1.28.2-0ubuntu1.1)
  • pango-graphite (0.9.3-0.2ubuntu1)

I solved it uninstalling pango-graphite and pango libs.

gnome-terminal just crashed and among all the libs listed in the dump, there was something about libpango. I checked what package provided it using:

dpkg -S /path/to/thelib.so

( Sorry I don't type the exact file, I couldn't write it down )

Then I removed the package and the fonts suddenly worked again. Maybe it was an old lib that kept around from an old installation. Other Ubuntu desktops I own don't have this libs installed.

share|improve this answer
1  
pango-graphite seemed to be the only thing I had to remove. –  tsbertalan Sep 3 '13 at 16:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.