Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently, I bought the laptop Dell Latitude E6530 and installed Ubuntu 13.04 64 bit (Raring Ringtail) alongside with Windows 7 (I could not get rid of it because of some special programs for work).

Ubuntu worked well. However, it did not detect the external displays (Dell 23" and Dell 19") no matter if I plugged them in before or after booting.

I connected my laptop to those external displays through a laptop dock.

Enter image description here

I went to Settings -> Display. The displays were there, but when I enabled them, Ubuntu logged off automatically. No external display was detected. In addition, the laptop screen sometimes was detected as Dell 23".

I got advice from similar topic that the Nvidia driver should be updated to version 313 or 319. I upgraded the driver and the Unity Launcher disappeared, main display resolution turned to 640*480 and none of the external displays were detected.

I tried to use additional drivers, but when I turned it on, it told me that there was no driver to be used.

What should I do?

I have set options vmwgfx enable_fbdev=1.

share|improve this question
Did you try fully uninstalling the prior nVidia drivers before updating to the new ones? Try issuing nvidia-installer --uninsall to do a full installation. After this, make sure you are using the original /etc/X11/Xorg.conf file that was in place before the original nVidia driver installation (the installer usually backs them up in sequence if I remember correctly). Then, attempt to re-install the newer nVidia drivers. – Chuck R May 24 '13 at 3:40
Also worth noting: I had issues on my ATI card (also using proprietary drivers) and external displays. I had to tweak something in the ATI control panel that allowed me to use the built-in Control Panel to set up my displays. The setting that I had to disable was the setting to use Xinerama. Even then, it took a lot of fiddling to get it to work properly. Take this with a grain of salt though, it's an apples-to-oranges comparison – Chuck R May 24 '13 at 3:40
I uninstalled but there was no Xorg.conf file there. The situation turned to upgrading situation, which I described before. – thuc2009 May 24 '13 at 6:34
Hmm... so this was after uninstalling the original driver or did you just uninstall the one you had? – Chuck R May 24 '13 at 6:48
the original driver is Intel(R) Ivybridge Mobile. I don't know how to remove or upgrade it :( – thuc2009 May 24 '13 at 7:43

Have you tried disabling Optimus in the BIOS? I had this issue as well with an E6530. I had to re-enable Optimus when booting Windows again, otherwise I had issues with wireless (I'm not sure if this was required though)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.