Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't change the screen brightness on my Fujitsu Amilo li3710. Pressing the keys (Fn+Brightness up) or sliding the bar in Brightness&Lock has no effect. It worked on windows so the function is supported by the hardware. Thanks for your help.

share|improve this question
    
I have the same setup. I just tried, and it works. Try sudo apt-get update && sudo apt-get upgrade. –  Mitch May 23 '13 at 16:09
    
I tried but still not working :(. Could you provide more details regarding your system? Are you using 32 or 64 bits version? –  user1377000 May 23 '13 at 16:36
    
Have you tried adding acpi_backlight=vendor to /etc/default/grub? If not open the terminal and type sudo gedit /etc/default/grub and where it says GRUB_CMDLINE_LINUX="quiet splash" change it to say GRUB_CMDLINE_LINUX="quiet splash acpi_backlight=vendor". Now save this file, and then in the terminal type sudo update-grub to apply the changes you just made. Reboot and then test the brightness controls! –  Merri May 23 '13 at 22:19
    
That's amazing, thanks! there was GRUB_CMDLINE_LINUX="" and GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"; I made them both "quiet splash acpi_backlight=vendor". I can now dim the brightness from Brightness&Lock. The Fn key binding is not working though, any ideas on how I might get that working? Thanks. –  user1377000 May 23 '13 at 22:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.