Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to 13.04 the hard drive media location keeps changing. These are installed hard drives not removable media. This issue does not seem to affect usability via the file managers (Nautilus and Dolphin) but it does affect symlinks.

In the following 'disk' represents the disk name and 'home' is my home directory name.

On one boot the media location is '/media/disk/' on another it's 'media/home/disk/'. There's no pattern that I've found so far as to when its one way or the other. The symlinks are written differently pending the mounting location. Some point to one location and other point to the other location. Their usability changes on rebooting where the ones that worked break and vise versa.

For example after I boot if I mount another drive it sometimes mounts at 'media/home/disk/'. If I mount another it mounts at 'media/disk/'. If I unmount the first that was at 'media/home/disk/' and remount that very same drive, it mounts at 'media/disk/'.

I was under the impression that internal hard drives ate supposed to be mounted at 'media/disk/' and removable media and disks at 'media/home/disk/'. Please correct me if I'm wrong.

So ultimately it seems that the underlying problem is where the drives are getting mounted. Then the question is where are they supposed to be mounted and why dosen't the system consistently mount them there?

I had a similar issue on upgrading to 12.10 but that seemed to be a bug and was resolved quickly.

Is this a bug or is it something I can fix permanently?

Thanks.

share|improve this question
    
Would you mind posting the contents of the file /etc/fstab (and also the device locations for the relevant drives, e.g. /dev/sda2)? It'd help with advising what to do next. –  Jez W May 23 '13 at 15:27
    
/etc/fstab: # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc nodev,noexec,nosuid 0 0 # / was on /dev/sdb1 during installation UUID=68bff081-9b80-4d38-8383-8dcf9f77850c / ext4 errors=remount-ro 0 1 # swap was on /dev/sdb5 during installation UUID=ada89abc-d3d6-4f5c-a4ed-176295a20842 none swap sw 0 0 /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0 –  Exomancer May 24 '13 at 2:59
    
/dev/sdc1 ---- I hope this helps. –  Exomancer May 24 '13 at 3:09

1 Answer 1

Since they're internal drives, it makes most sense to mount them statically. You can add lines to your /etc/fstab file in order to define your own mount point. See for example mine (I have two partitions apart from /, which I have mounted to /data/ and /media/Windows, for instance)

/etc/fstab example

First, run sudo blkid, this will tell you the UUID for all drives attached to your system. Then add the following lines before the line #swap was on /dev/sdb5 during installation:

#Entry for /dev/sdc1
UUID=[UUID]    [mountpoint]    [type]    defaults    0    [pass]

where [UUID] is the number you found from blkid, [mountpoint] is a directory (you can create this wherever you want, possibly requiring sudo mkdir if in the root of the system); [type] is the filesystem in use (usually ext4 or ntfs), and [pass], from what I can gather, is best put as 2 for a secondary ext4 drive or 0 for an ntfs one (it has to do with how the filesystem checker, fsck, behaves with it - this could be false advice for ntfs, but for me at least it's trundled along quite nicely)

See here for further guidance: https://help.ubuntu.com/community/MoveMountpointHowto

Hope this helps!

share|improve this answer
    
Thanks for the cogent answer but to be honest this terrifies me and is WAY over my head. I understand what you are saying but looking at the details from your post and the how-to link is just beyond me. I'm afraid that I'll totally mess up my system if I do something wrong. Again thanks but I'll just unmount and remount the drive and hope it fixes itself like it has been. Maybe someday I'll finally learn all these details. –  Exomancer May 25 '13 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.