Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu 12.04, I added a network printer which I had previously used without any problems on a different machine (with the same release of Ubuntu).

Now, with the default generic driver installed, printing multiple pages per sheet from evince doesn't work properly. If I select 2 per sheet, be it long or short edge, it always prints 4.

Why is this?

It used to happen with non-pdf documents in the past, like from a browser. My workaround was to print to pdf file and then print the pdf itself. Now I'm clueless...

Edit: the same happens with a different network printer, in which I installed the driver specific to its particular model.

share|improve this question
    
I have the same problem and its not resolved for me. Apparently, choosing "2 pages per sheet" in evince, changes both the behaviour of evince and the printer (or driver or cups), so that I always get 4 per sheet, which is not what I want. –  Jan Oct 21 '13 at 12:04
    
Glad to hear I'm not the only one with this issue... –  Ricky Robinson Oct 21 '13 at 12:28
add comment

2 Answers

Just guessing from sparse / generic information provided, there basically are two places/points worth looking into:

  • In "Printing" (configure printers, etc), check "page-per-sheet" settings there.

  • In Evince, again check "page-per-sheet" settings there.

Further, you may want to try printing from yet another application like *office or gedit (and browse their resp. printing options) for comparison and to confine/define the problem.

Good luck ! (with saving paper :)

share|improve this answer
    
I changed the double-siding printing option to None (from Long Edge) and on Gedit it seems to work. From evince and the default dialog box it still prints 4 pages. I don't know what went wrong here. I checked everything: system-config-printer, http://localhost:631/ and of course the settings when I print. Nothing. Nada. –  Ricky Robinson Jun 18 '13 at 8:43
    
re-install evince ? –  nutty about natty Jun 18 '13 at 13:30
    
I did sudo apt-get remove evince, sudo apt-get purge evince, followed by sudo apt-get install evince, but I still have the same problem. :( I've been using and printing with evince for years, using all possible combinations of paper orientation and number of pages per sheet, so I know more or less what I am doing. I just have no idea why this is happening. I might attribute it the driver associated with the printer. I'll try changing that. –  Ricky Robinson Jun 18 '13 at 13:42
    
sorry to hear! good luck. ps: afterthought: possibly re-install (or update/upgrade version of) CUPS ??? careful: haven't done it myself... –  nutty about natty Jun 18 '13 at 19:03
add comment

I have the same problem on Debian Wheezy. You can use xournal, that is very useful and has a similar, but not bugged, printing system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.